]> code.ossystems Code Review - openembedded-core.git/commitdiff
dpkg, opkg, rpm-postinsts: avoid repackaging when changing IMAGE_FEATURES
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Thu, 11 Apr 2013 14:55:15 +0000 (15:55 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 11 Apr 2013 15:13:50 +0000 (16:13 +0100)
Recipes cannot depend on the value of IMAGE_FEATURES; in this case the
result is do_package task signatures changing every time IMAGE_FEATURES
changes, causing a large number of task re-executions. The
implementation of the log capturing really needs to be changed to
capture these in a different place and possibly not even conditional
upon IMAGE_FEATURES at all, but this will be invasive at this point in
the development cycle. For now, remove the variable dependencies to fix
the immediate problem.

Fixes [YOCTO #4246].

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/dpkg/dpkg.inc
meta/recipes-devtools/opkg/opkg.inc
meta/recipes-devtools/rpm/rpm-postinsts.bb

index 555492089fd1867348aea272a2933016f96dc134..35cd6e71b82b4213d71a5d7ddb0d3b1428673f2f 100644 (file)
@@ -37,6 +37,7 @@ do_configure () {
 
 POSTLOG ?= "/var/log/postinstall.log"
 REDIRECT_CMD = "${@base_contains('IMAGE_FEATURES', 'debug-tweaks', '>${POSTLOG} 2>&1', '', d)}"
+REDIRECT_CMD[vardepsexclude] += "IMAGE_FEATURES POSTLOG"
 
 DPKG_INIT_POSITION ?= "98"
 
index ff26b04b6eec81d277949d6e2dd0d9c9b5982ee6..c1798b16232183d8c67fc42406f57273f0ada9c9 100644 (file)
@@ -59,6 +59,7 @@ do_install_append_class-native() {
 
 POSTLOG ?= "/var/log/postinstall.log"
 REDIRECT_CMD = "${@base_contains('IMAGE_FEATURES', 'debug-tweaks', '>${POSTLOG} 2>&1', '', d)}"
+REDIRECT_CMD[vardepsexclude] += "IMAGE_FEATURES POSTLOG"
 
 pkg_postinst_${PN} () {
 #!/bin/sh
index b551c8d4f07ae0c2ea2a3035f2a14ef7ba4dfacf..a5310b53bfef989264c73602976800563d305035 100644 (file)
@@ -13,6 +13,7 @@ POSTINSTALL_INITPOSITION ?= "98"
 
 POSTLOG ?= "/var/log/postinstall.log"
 REDIRECT_CMD = "${@base_contains('IMAGE_FEATURES', 'debug-tweaks', '>>${POSTLOG} 2>&1', '', d)}"
+REDIRECT_CMD[vardepsexclude] += "IMAGE_FEATURES POSTLOG"
 
 do_fetch() {
        :