]> code.ossystems Code Review - openembedded-core.git/commitdiff
ocf-linux: Add ocf-linux to support openssl 1.0
authorSaul Wold <sgw@linux.intel.com>
Mon, 28 Nov 2011 22:17:21 +0000 (14:17 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Nov 2011 15:03:41 +0000 (15:03 +0000)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/openssl/ocf-linux.inc [new file with mode: 0644]
meta/recipes-connectivity/openssl/ocf-linux_20100325.bb [new file with mode: 0644]

diff --git a/meta/recipes-connectivity/openssl/ocf-linux.inc b/meta/recipes-connectivity/openssl/ocf-linux.inc
new file mode 100644 (file)
index 0000000..f4ec7c9
--- /dev/null
@@ -0,0 +1,25 @@
+DESCRIPTION = "Install required headers to enable OCF Linux support"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://README;md5=b02a793c9b7893b4ce1f39f0b231ccd7"
+INC_PR = "r3"
+
+SRC_URI = "http://sourceforge.net/projects/ocf-linux/files/ocf-linux/${PV}/ocf-linux-${PV}.tar.gz"
+
+S = "${WORKDIR}/ocf-linux-${PV}"
+
+# Need to unpack the the ocf-linux.tar.gz file contained inside the
+# downloaded tarball
+# Install the OCF Linux headers so that other packages such as openssl
+# can find them.  The headers must be in a crypto directory according to
+# the README file.
+do_install() {
+    cd ${S}
+    tar xzf ocf-linux.tar.gz
+    install -d ${D}${includedir}/crypto
+    install -m 0644 ${S}/ocf/*.h ${D}${includedir}/crypto/
+}
+
+ALLOW_EMPTY = "1"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-connectivity/openssl/ocf-linux_20100325.bb b/meta/recipes-connectivity/openssl/ocf-linux_20100325.bb
new file mode 100644 (file)
index 0000000..9dccc3c
--- /dev/null
@@ -0,0 +1,6 @@
+require ocf-linux.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "ce5ad54aa94226d496df1f0f3cf0c11f"
+SRC_URI[sha256sum] = "9d17cbd13849939c70699b520280e3b94cf77401cdc131108d4aeaaeea587f6b"