]> code.ossystems Code Review - openembedded-core.git/commitdiff
createrepo: add wrapper script to fix paths
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Mon, 13 Aug 2012 18:58:00 +0000 (18:58 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 13 Aug 2012 19:09:22 +0000 (20:09 +0100)
Fixes sstate relocation due to the path to /etc/rpm being baked into the
libraries - this manifested in the form of the following assertion at
runtime:

python: dbconfig.c:493: db3New: Assertion `dbOpts != ((void *)0) && *dbOpts != '\0'' failed.

Fixes [YOCTO #2753].

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/createrepo/createrepo_0.4.11.bb

index 42c7214bb28dcbe6ac721a4cb0a26127baf0f10f..344cc77770373ae90b352a08045e5f6d444e1eb3 100644 (file)
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
 
 RDEPENDS_${PN}_virtclass-native += "libxml2-native rpm-native"
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI= "http://createrepo.baseurl.org/download/${BP}.tar.gz \
           file://fix-native-install.patch \
@@ -36,4 +36,9 @@ do_install_append_virtclass-native () {
                 ${D}${bindir}/rpm-createsolvedb.py ; do
                create_wrapper $i ${STAGING_BINDIR_NATIVE}/python-native/python
        done
+
+       create_wrapper ${D}/${bindir}/createrepo \
+                       RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
+                       RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
+                       RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
 }