]> code.ossystems Code Review - openembedded-core.git/commitdiff
xmlto: clean up RDEPENDS
authorRoss Burton <ross.burton@intel.com>
Thu, 4 Apr 2019 22:16:43 +0000 (23:16 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Apr 2019 16:27:40 +0000 (17:27 +0100)
Because of differences in how RDEPENDS works for native/target, add libxml2 and
libxslt to RDEPENDS (so that native dependencies work), but also add
libxml2-utils (for xmllint) and libxslt-bin (for xsltproc) to target RDEPENDS.

Also add libxml2-native to DEPENDS as that is needed for the
docbook-(xml,xsl)-native catalog to be generated.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/xmlto/xmlto_0.0.28.bb

index 06dc002083d78c8fc9e9bf5ca4bef69124dbe680..df798dfcdde48601f644e1d66acfe5f9ac4dcf10 100644 (file)
@@ -12,16 +12,18 @@ SRC_URI[md5sum] = "a1fefad9d83499a15576768f60f847c6"
 SRC_URI[sha256sum] = "2f986b7c9a0e9ac6728147668e776d405465284e13c74d4146c9cbc51fd8aad3"
 
 inherit autotools
-RDEPENDS_class-native = "libxslt-native"
 
-# xmlto needs getopt/xmllint/xsltproc/bash/tail at runtime
+DEPENDS = "libxml2-native"
+
 RDEPENDS_${PN} = "docbook-xml-dtd4 \
                   docbook-xsl-stylesheets \
                   util-linux \
                   libxml2 \
+                  libxslt \
                   bash \
 "
 RDEPENDS_${PN}_append_class-target = " \
+                  libxml2-utils \
                   libxslt-bin \
                   coreutils \
 "