]> code.ossystems Code Review - openembedded-core.git/commitdiff
less: Add alternatives handling from OE.dev
authorRichard Purdie <richard@openedhand.com>
Tue, 21 Nov 2006 10:44:15 +0000 (10:44 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 21 Nov 2006 10:44:15 +0000 (10:44 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@912 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/less/less_382.bb

index b489722edbb5d0cbb3ed61b985b631de73df3891..f336a59ad6a78dfd3d144dcc1e6294f15359e21f 100644 (file)
@@ -1,16 +1,22 @@
-SECTION = "console/utils"
-DEPENDS = "ncurses"
 DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
 based program for viewing text files and the output from other \
 programs. Less offers many features beyond those that more does."
 HOMEPAGE = "http://www.greenwoodsoftware.com/"
+SECTION = "console/utils"
 LICENSE = "BSD"
+DEPENDS = "ncurses"
+PR = "r1"
 
 SRC_URI = "${GNU_MIRROR}/less/less-${PV}.tar.gz \
-          file://configure.patch;patch=1"
+           file://configure.patch;patch=1"
 
-inherit autotools
+inherit autotools update-alternatives
 
 do_install () {
-       oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+        oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+        mv ${D}${bindir}/less ${D}${bindir}/less.${PN}
 }
+
+ALTERNATIVE_NAME = "less"
+ALTERNATIVE_PATH = "less.${PN}"
+ALTERNATIVE_PRIORITY = "100"