]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg: ensure the data directory is created
authorJoshua Lock <josh@linux.intel.com>
Thu, 10 Jun 2010 14:04:38 +0000 (15:04 +0100)
committerJoshua Lock <josh@linux.intel.com>
Thu, 10 Jun 2010 14:04:38 +0000 (15:04 +0100)
We need to ensure the data directory (/usr/lib/opkg) is created and shipped in
the package as it's used by opkg to create a lock file.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/packages/opkg/opkg_svn.bb

index 9d8bec8187f28db63fe754a8e756b94a5e9fe74c..c3192bea50e00b741b07b53805e6c82059748442 100644 (file)
@@ -8,13 +8,18 @@ RDEPENDS_${PN}_virtclass-native = ""
 RDEPENDS_${PN}_virtclass-nativesdk = ""
 PACKAGE_ARCH_update-alternatives-cworth = "all"
 
-PR = "r12"
+PR = "r13"
 
 PACKAGES =+ "libopkg-dev libopkg update-alternatives-cworth"
 
 FILES_update-alternatives-cworth = "${bindir}/update-alternatives"
 FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
-FILES_libopkg = "${libdir}/*.so.*"
+FILES_libopkg = "${libdir}/*.so.* ${libdir}/opkg/"
+
+# We need to create the lock directory
+do_install_append() {
+    install -d ${D}${libdir}/opkg
+}
 
 # Define a variable to allow distros to run configure earlier.
 # (for example, to enable loading of ethernet kernel modules before networking starts)