]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Patch out gcc3 checks, limit the target list
authorRichard Purdie <richard@openedhand.com>
Fri, 25 Apr 2008 08:28:26 +0000 (08:28 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 25 Apr 2008 08:28:26 +0000 (08:28 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4336 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/qemu/qemu-0.9.1+svn/remove_gcc3_check.patch [new file with mode: 0644]
meta/packages/qemu/qemu_svn.bb

diff --git a/meta/packages/qemu/qemu-0.9.1+svn/remove_gcc3_check.patch b/meta/packages/qemu/qemu-0.9.1+svn/remove_gcc3_check.patch
new file mode 100644 (file)
index 0000000..3a180ec
--- /dev/null
@@ -0,0 +1,54 @@
+Index: trunk/configure
+===================================================================
+--- trunk.orig/configure       2008-04-25 09:09:31.000000000 +0100
++++ trunk/configure    2008-04-25 09:11:31.000000000 +0100
+@@ -22,8 +22,6 @@
+ static="no"
+ cross_prefix=""
+ cc="gcc"
+-gcc3_search="yes"
+-gcc3_list="gcc-3.4.6 gcc-3.4 gcc34 gcc-3.3.6 gcc-3.3 gcc33 gcc-3.2 gcc32"
+ host_cc="gcc"
+ ar="ar"
+ make="make"
+@@ -245,9 +243,6 @@
+   ;;
+   --cross-prefix=*) cross_prefix="$optarg"
+   ;;
+-  --cc=*) cc="$optarg"
+-  gcc3_search="no"
+-  ;;
+   --host-cc=*) host_cc="$optarg"
+   ;;
+   --make=*) make="$optarg"
+@@ -479,30 +474,6 @@
+ #endif
+ int main(){return 0;}
+ EOF
+-    if "$cc" $ARCH_CFLAGS -o $TMPE $TMPC 2> /dev/null ; then
+-      echo "WARNING: \"$cc\" looks like gcc 4.x"
+-      found_compat_cc="no"
+-      if test "$gcc3_search" = "yes" ; then
+-          echo "Looking for gcc 3.x"
+-          for compat_cc in $gcc3_list ; do
+-              if "$cross_prefix$compat_cc" --version 2> /dev/null | fgrep '(GCC) 3.' > /dev/null 2>&1 ; then
+-                  echo "Found \"$compat_cc\""
+-                  cc="$cross_prefix$compat_cc"
+-                  found_compat_cc="yes"
+-                  break
+-              fi
+-          done
+-          if test "$found_compat_cc" = "no" ; then
+-              echo "gcc 3.x not found!"
+-          fi
+-      fi
+-      if test "$found_compat_cc" = "no" ; then
+-          echo "QEMU is known to have problems when compiled with gcc 4.x"
+-          echo "It is recommended that you use gcc 3.x to build QEMU"
+-          echo "To use this compiler anyway, configure with --disable-gcc-check"
+-          exit 1;
+-      fi
+-    fi
+ fi
+ #
index 2feb4724d8ad0d3f9eda2d19c2abcadd5597c54b..1fc9446877d21440ac3609a6e3019cb0ad9ca668 100644 (file)
@@ -1,7 +1,7 @@
 LICENSE = "GPL"
 DEPENDS = "zlib"
 PV = "0.9.1+svnr${SRCREV}"
-PR = "r6"
+PR = "r7"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-0.9.1+svn/"
 
@@ -30,12 +30,13 @@ SRC_URI = "\
     file://no-strip.patch;patch=1 \
     file://fix_brk.patch;patch=1 \
     file://fix_protection_bits.patch;patch=1 \
+    file://remove_gcc3_check.patch;patch=1 \
     file://qemu-n800-support.patch;patch=1"
 
 S = "${WORKDIR}/trunk"
 
 #EXTRA_OECONF += "--disable-sdl"
-#EXTRA_OECONF += "--target-list=arm-linux-user,arm-softmmu"
+EXTRA_OECONF += "--target-list=arm-linux-user,arm-softmmu,i386-softmmu"
 EXTRA_OECONF += "--disable-gfx-check"
 
 inherit autotools