]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pycurl: upgrade to 7.19.3
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 6 Feb 2014 15:29:32 +0000 (17:29 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 8 Feb 2014 21:03:27 +0000 (21:03 +0000)
Changes:
 * Refreshed no-static-link.patch;
 * LGPL&MIT license files changed names;
 * MIT license file added a contributor to the list;
 * README.rst license snippet changed to reflect the filename changes
   and the new contributor;

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-pycurl/no-static-link.patch
meta/recipes-devtools/python/python-pycurl_7.19.3.bb [moved from meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb with 59% similarity]

index e8c0005a77f21ba9bce2db2504587d4385053346..907380f1ca282d261ec28d410c34ce641eda777c 100644 (file)
@@ -1,15 +1,17 @@
 Upstream-Status: Pending
 
-Index: pycurl-7.19.0.2/setup.py
+Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
+
+Index: pycurl-7.19.3/setup.py
 ===================================================================
---- pycurl-7.19.0.2.orig/setup.py      2013-10-08 15:28:53.000000000 +0300
-+++ pycurl-7.19.0.2/setup.py   2013-11-04 13:46:47.928292585 +0200
-@@ -101,7 +101,7 @@
-     # support one or the other of these curl-config options, so gracefully
-     # tolerate failure of either, but not both.
+--- pycurl-7.19.3.orig/setup.py        2014-01-10 08:04:40.000000000 +0200
++++ pycurl-7.19.3/setup.py     2014-02-04 15:09:08.411552887 +0200
+@@ -211,7 +211,7 @@
+     # If neither --libs nor --static-libs work, fail.
      optbuf = ""
+     errtext = ''
 -    for option in ["--libs", "--static-libs"]:
 +    for option in ["--libs"]:
-         p = subprocess.Popen("'%s' %s" % (CURL_CONFIG, option), shell=True,
-             stdout=subprocess.PIPE)
-         (stdout, stderr) = p.communicate()
+         p = subprocess.Popen((CURL_CONFIG, option),
+             stdout=subprocess.PIPE, stderr=subprocess.PIPE)
+         stdout, stderr = p.communicate()
similarity index 59%
rename from meta/recipes-devtools/python/python-pycurl_7.19.0.2.bb
rename to meta/recipes-devtools/python/python-pycurl_7.19.3.bb
index aceaab34cb79ad2b08b629e174183f96bbdf62c1..aee6cdda82377a44fd7155639c62768f00b532c5 100644 (file)
@@ -2,9 +2,9 @@ SUMMARY = "Python bindings for libcurl"
 HOMEPAGE = "http://pycurl.sourceforge.net/"
 SECTION = "devel/python"
 LICENSE = "LGPLv2.1+ | MIT"
-LIC_FILES_CHKSUM = "file://README.rst;beginline=97;endline=111;md5=b5a5e531d80812bcbecbeb240fde63ef \
-                    file://COPYING;md5=3579a9fd0221d49a237aaa33492f988c \
-                    file://COPYING2;md5=ffaa1e283b7f9bf5aafd8d45db6f7518"
+LIC_FILES_CHKSUM = "file://README.rst;beginline=204;endline=219;md5=57e5ab0c0f964533fc59d93dec5695bb \
+                    file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \
+                    file://COPYING-MIT;md5=e8200955c773b2a0fd6cea36ea5e87be"
 
 DEPENDS = "curl python"
 RDEPENDS_${PN} = "python-core curl"
@@ -15,8 +15,8 @@ SRC_URI = "\
   file://no-static-link.patch \
 "
 
-SRC_URI[archive.md5sum] = "518be33976dbc6838e42495ada64b43f"
-SRC_URI[archive.sha256sum] = "7a9e793b9181654d5eef3f6d22c244c57d2b51d38feb4c1b71d68efda99b0547"
+SRC_URI[archive.md5sum] = "b9091b7438d3de1552e28862d2971cd1"
+SRC_URI[archive.sha256sum] = "05e48835fe445ff327dcd373f49d9970e0b828a07cd4d08a23264507a742d616"
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils