]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance-image: Drop kernel module handling
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 8 Mar 2021 16:46:50 +0000 (16:46 +0000)
committerSteve Sakoman <steve@sakoman.com>
Thu, 11 Mar 2021 15:00:02 +0000 (05:00 -1000)
kernel-devsrc is a dependency of the image so we no longer need the symlink
creation code or the module-base inherit/dependency as it is included in
that recipe. The KERNEL_VERSION usage was broken anyway as the module
usage would have needed a:

do_image[depends] += "build-appliance-image:do_configure"

which wasn't present so it was indeterminate if KERNEL_VERSION was set
correctly.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit a46b43bb67b2f87ec370480e50a2e2d111555b75)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-core/images/build-appliance-image_15.0.0.bb

index f5cc20fa6d8377e0ea7716ee11fdb403d91099cf..086e20023f8729c38bd1d1960eb936f7da06b715 100644 (file)
@@ -22,7 +22,7 @@ APPEND += "rootfstype=ext4 quiet"
 DEPENDS = "zip-native python3-pip-native"
 IMAGE_FSTYPES = "wic.vmdk"
 
-inherit core-image module-base setuptools3
+inherit core-image setuptools3
 
 SRCREV ?= "fadf7d3343305337c38a5243797723c68e88276a"
 SRC_URI = "git://git.yoctoproject.org/poky;branch=dunfell \
@@ -61,12 +61,6 @@ fakeroot do_populate_poky_src () {
        # Place the README_VirtualBox_Toaster file in builders home folder.
        cp ${WORKDIR}/README_VirtualBox_Toaster.txt ${IMAGE_ROOTFS}/home/builder/
 
-       # Create a symlink, needed for out-of-tree kernel modules build
-       if [ ! -e ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build ]; then
-               rm -f  ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
-               lnr ${IMAGE_ROOTFS}${KERNEL_SRC_PATH} ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
-       fi
-
        echo "INHERIT += \"rm_work\"" >> ${IMAGE_ROOTFS}/home/builder/poky/build/conf/auto.conf
        echo "export LC_ALL=en_US.utf8" >> ${IMAGE_ROOTFS}/home/builder/.bashrc