]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: fix for host contamination issue while cross compiling
authorNitin A Kamble <nitin.a.kamble@intel.com>
Mon, 11 Oct 2010 21:33:54 +0000 (14:33 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 11 Oct 2010 21:53:45 +0000 (22:53 +0100)
This fixes [BUGID #385]

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-devtools/python/python.inc
meta/recipes-devtools/python/python/06-avoid_usr_lib_termcap_path_in_linking.patch [new file with mode: 0644]
meta/recipes-devtools/python/python_2.6.5.bb

index 682bd5a2dade54fc631b4f53d19483fc5ecaacfe..62a6ba158923eef702d110c8a94a17c3f415f66a 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "PSF"
 SECTION = "devel/python"
 PRIORITY = "optional"
 # bump this on every change in contrib/python/generate-manifest-2.6.py
-INC_PR = "ml8"
+INC_PR = "nk0"
 
 DEFAULT_PREFERENCE = "-26"
 
diff --git a/meta/recipes-devtools/python/python/06-avoid_usr_lib_termcap_path_in_linking.patch b/meta/recipes-devtools/python/python/06-avoid_usr_lib_termcap_path_in_linking.patch
new file mode 100644 (file)
index 0000000..30aa50d
--- /dev/null
@@ -0,0 +1,27 @@
+The poison directories patch has detected library path issue while 
+compiling the python in cross environment, as seen bellow.
+
+warning: library search path "/usr/lib/termcap" is unsafe for cross-compilation
+
+This Patch fixes this issue in the python build environment.
+11 Oct 2010
+Nitin A Kamble <nitin.a.kamble@intel.com>
+
+Index: Python-2.6.5/setup.py
+===================================================================
+--- Python-2.6.5.orig/setup.py
++++ Python-2.6.5/setup.py
+@@ -591,12 +591,10 @@ class PyBuildExt(build_ext):
+                 readline_libs.append('ncurses')
+             elif self.compiler.find_library_file(lib_dirs, 'curses'):
+                 readline_libs.append('curses')
+-            elif self.compiler.find_library_file(lib_dirs +
+-                                               ['/usr/lib/termcap'],
++            elif self.compiler.find_library_file(lib_dirs,
+                                                'termcap'):
+                 readline_libs.append('termcap')
+             exts.append( Extension('readline', ['readline.c'],
+-                                   library_dirs=['/usr/lib/termcap'],
+                                    extra_link_args=readline_extra_link_args,
+                                    libraries=readline_libs) )
+         else:
index 9658fd48dc50119800907667326004aa2b59a330..674b673f940718c1f84bd0e5b1accea4d9d90095 100644 (file)
@@ -2,7 +2,7 @@ require python.inc
 DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
 DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
 # set to .0 on every increase of INC_PR
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
 
 SRC_URI = "\
   http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -12,6 +12,7 @@ SRC_URI = "\
   file://03-fix-tkinter-detection.patch \
   file://04-default-is-optimized.patch \
   file://05-enable-ctypes-cross-build.patch \
+  file://06-avoid_usr_lib_termcap_path_in_linking.patch \
   file://99-ignore-optimization-flag.patch \
   file://sitecustomize.py \
 "