]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu-helper-native: pass compiler flags
authorRoss Burton <ross.burton@intel.com>
Mon, 14 Oct 2019 14:08:59 +0000 (15:08 +0100)
committerArmin Kuster <akuster808@gmail.com>
Sun, 10 Nov 2019 22:11:42 +0000 (14:11 -0800)
Pass all of the compiler and linker flags so the build is correctly configured.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb

index d9d9da0fadebe2a7685bd6dd9f6ef45411f25fac..372eebd88648a1aba1f3609de593b36360aa3c50 100644 (file)
@@ -12,7 +12,7 @@ S = "${WORKDIR}"
 inherit native
 
 do_compile() {
-       ${CC} tunctl.c -o tunctl
+       ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
 }
 
 do_install() {