]> code.ossystems Code Review - openembedded-core.git/commitdiff
clutter: Fix so 0.4 versions are default (which matches distro config SRCREVs) and...
authorRichard Purdie <richard@openedhand.com>
Tue, 6 Nov 2007 23:11:42 +0000 (23:11 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 6 Nov 2007 23:11:42 +0000 (23:11 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3084 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/distro/poky.conf
meta/packages/clutter/clutter-gst/autofoo-0.4.patch [new file with mode: 0644]
meta/packages/clutter/clutter-gst_0.4svn.bb
meta/packages/clutter/clutter-gst_svn.bb
meta/packages/clutter/clutter.inc
meta/packages/clutter/clutter/enable_tests-0.4.patch [new file with mode: 0644]
meta/packages/clutter/clutter_0.4svn.bb
meta/packages/clutter/clutter_svn.bb

index 89993acb763aa2d5c5b78d503050326a2fcf178c..9fe31ad9064b9842f01b80f187633628e89af9e6 100644 (file)
@@ -126,7 +126,7 @@ SRCREV_pn-fstests ?= "266"
 SRCDATE_abiword ?= "20070130"
 SRCREV_pn-xvideo-tests ?= "272"
 SRCREV_pn-clutter ?= "1495"
-SRCREV_pn-clutter-gst ?= "1317"
+SRCREV_pn-clutter-gst ?= "1495"
 SRCDATE_libgsmd ?= "20070917"
 SRCREV_pn-gaku ?= "286"
 SRCREV_pn-gypsy ?= "39"
diff --git a/meta/packages/clutter/clutter-gst/autofoo-0.4.patch b/meta/packages/clutter/clutter-gst/autofoo-0.4.patch
new file mode 100644 (file)
index 0000000..54df63d
--- /dev/null
@@ -0,0 +1,15 @@
+---
+ doc/reference/Makefile.am |    2 +-
+ examples/Makefile.am      |    2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: clutter-gst/examples/Makefile.am
+===================================================================
+--- clutter-gst.orig/examples/Makefile.am      2007-11-06 12:31:36.000000000 +0000
++++ clutter-gst/examples/Makefile.am   2007-11-06 18:53:59.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = video-player video-sink audio
++bin_PROGRAMS = video-player video-sink audio
+ INCLUDES = -I$(top_srcdir)/
index fa7afe0f96612a1d2e07525f778b1d8c4eda230d..1af797888c26fc570096dbb13975ca8b251046d6 100644 (file)
@@ -1,9 +1,9 @@
 require clutter-gst.inc
 
-DEFAULT_PREFERENCE = "-1"
-
 PV = "0.4.0+svnr${SRCREV}"
 
-SRC_URI = "svn://svn.o-hand.com/repos/clutter/branches;module=clutter-gst-0-4;proto=http "
+SRC_URI = "svn://svn.o-hand.com/repos/clutter/branches;module=clutter-gst-0-4;proto=http \
+           file://autofoo-0.4.patch;patch=1"
+
 
 S = "${WORKDIR}/clutter-gst-0-4"
index 6afb4f52de0faf5f41578e1fd161c7149cc7d790..b4d41d6830f846e958d3d1bb8585b6838bf5f2bb 100644 (file)
@@ -1,10 +1,10 @@
 require clutter-gst.inc
 
-PV = "0.4.0+svnr${SRCREV}"
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.5.0+svnr${SRCREV}"
 
 SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=${PN};proto=http \
            file://autofoo.patch;patch=1"
 
 S = "${WORKDIR}/${PN}"
-
-
index 8cb44b28f8032008855ae39ebf9f9c5b2d5397a6..ac633dc74ac6507acdd1cf324ac5cee295d54026 100644 (file)
@@ -34,7 +34,6 @@ do_configure_prepend() {
 }
 
 do_stage () {
-       cp ${S}/clutter.pc ${S}/clutter-0.4.pc
+       cp ${S}/clutter.pc ${S}/clutter-0.5.pc
         autotools_stage_all
 }
-
diff --git a/meta/packages/clutter/clutter/enable_tests-0.4.patch b/meta/packages/clutter/clutter/enable_tests-0.4.patch
new file mode 100644 (file)
index 0000000..3178a2c
--- /dev/null
@@ -0,0 +1,52 @@
+---
+ tests/Makefile.am   |    7 ++++++-
+ tests/test-actors.c |    2 +-
+ tests/test-text.c   |    2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter-0-4/tests/Makefile.am
+===================================================================
+--- clutter-0-4.orig/tests/Makefile.am 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/Makefile.am      2007-11-06 21:49:48.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+                   test-actors test-behave test-text test-entry test-project \
+                 test-boxes test-perspective test-rotate test-depth \
+                 test-threads test-timeline
+@@ -24,4 +24,9 @@ test_depth_SOURCES     = test-depth.c
+ test_threads_SOURCES   = test-threads.c
+ test_timeline_SOURCES  = test-timeline.c
++test_textdir           = $(pkgdatadir)
++test_text_DATA         = test-text.c
++test_actorsdir         = $(pkgdatadir)
++test_actors_DATA       = redhand.png
++
+ EXTRA_DIST = redhand.png
+Index: clutter-0-4/tests/test-actors.c
+===================================================================
+--- clutter-0-4.orig/tests/test-actors.c       2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-actors.c    2007-11-06 21:49:28.000000000 +0000
+@@ -143,7 +143,7 @@ main (int argc, char *argv[])
+   stage = clutter_stage_get_default ();
+   clutter_actor_set_size (stage, 800, 600);
+-  pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++  pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+   if (!pixbuf)
+     g_error("pixbuf load failed");
+Index: clutter-0-4/tests/test-text.c
+===================================================================
+--- clutter-0-4.orig/tests/test-text.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-text.c      2007-11-06 21:49:28.000000000 +0000
+@@ -27,7 +27,7 @@ main (int argc, char *argv[])
+   stage = clutter_stage_get_default ();
+-  if (!g_file_get_contents ("test-text.c", &text, &size, NULL)) 
++  if (!g_file_get_contents ("/usr/share/clutter/test-text.c", &text, &size, NULL))
+     g_error("g_file_get_contents() of test-text.c failed");
+   clutter_actor_set_size (stage, 800, 600);
index 0bd32b61243fdfb1df516f978bc4d028439fed60..fe1fbc29d3855dec868e88b3bb47eb906b310d0a 100644 (file)
@@ -1,10 +1,13 @@
 require clutter.inc
 
-DEFAULT_PREFERENCE = "-1"
-
 PV = "0.4.0+svnr${SRCREV}"
 
 SRC_URI = "svn://svn.o-hand.com/repos/clutter/branches;module=clutter-0-4;proto=http \
-          file://enable_tests.patch;patch=1 "
+          file://enable_tests-0.4.patch;patch=1 "
 
 S = "${WORKDIR}/clutter-0-4"
+
+do_stage () {
+        cp ${S}/clutter.pc ${S}/clutter-0.4.pc
+        autotools_stage_all
+}
index 0a6ff0d688fa566b43b0ded80fda052c2df4499e..a0015ba42e5625bff153b8ae6af2129d38c16760 100644 (file)
@@ -1,6 +1,8 @@
 require clutter.inc
 
-PV = "0.4.0+svnr${SRCREV}"
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.5.0+svnr${SRCREV}"
 
 SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=clutter;proto=http \
           file://enable_tests.patch;patch=1 "