]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash: fix buildpaths qa check error
authorKai Kang <kai.kang@windriver.com>
Thu, 24 Dec 2015 09:47:53 +0000 (17:47 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 7 Jan 2016 13:40:09 +0000 (13:40 +0000)
Script bashbug and Makefile for ptest contain build related paths
which cause fail to pass buldpaths QA check.

Remove such paths from these 2 files.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/bash/bash.inc

index 85639d3bb95eae44f9eba7920b6d05879f91f393..93ca00b25cdb0149ede4639aad7635eda663b352 100644 (file)
@@ -45,13 +45,15 @@ do_install_append () {
 }
 do_install_append_class-target () {
        # Clean host path in bashbug
-       sed -i -e "s,${STAGING_DIR_TARGET},,g" ${D}${bindir}/bashbug
+       sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
+               -e "s,-I${WORKDIR}/\S* ,,g" ${D}${bindir}/bashbug
 }
 
 do_install_ptest () {
        make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
        cp ${B}/Makefile ${D}${PTEST_PATH}
-        sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+        sed -i -e 's/^Makefile/_Makefile/' -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
+           -e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" ${D}${PTEST_PATH}/Makefile
 }
 
 pkg_postinst_${PN} () {