]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: make it explicit that valgrind supports armv7a and above
authorAndre McCurdy <armccurdy@gmail.com>
Wed, 13 Jan 2016 03:24:30 +0000 (19:24 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 19 Jan 2016 17:37:24 +0000 (17:37 +0000)
Despite rumours to the contrary, valgrind really does require
armv7a or above.

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/valgrind/valgrind_3.11.0.bb

index 00217fa9d3a0d84dd7ff2caa8b582a925fcda66c..70d84fe9a244dcbb928eda30d04ad4647d1c9435 100644 (file)
@@ -29,6 +29,11 @@ SRC_URI[sha256sum] = "6c396271a8c1ddd5a6fb9abe714ea1e8a86fce85b30ab26b4266aeb4c2
 
 COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
 
+# valgrind supports armv7 and above
+COMPATIBLE_HOST_armv4 = 'null'
+COMPATIBLE_HOST_armv5 = 'null'
+COMPATIBLE_HOST_armv6 = 'null'
+
 inherit autotools ptest
 
 EXTRA_OECONF = "--enable-tls --without-mpicc"