]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: add PACKAGECONFIG to build with compatibility libraries
authorJoshua Lock <joshua.lock@collabora.co.uk>
Tue, 13 Oct 2015 16:07:33 +0000 (17:07 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Nov 2015 11:20:12 +0000 (11:20 +0000)
Systemd < 209 shipped separate pc files for various interfaces, these
can still be generated for compatibility with code using the older
interfaces.

Add a PACKAGECONFIG option to build systemd with the compatibility
pc files.

Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_225.bb

index 18c24481249e586d9307054f20112bd3d4ab912c..6936149fbdc2457a48a4ee14f23028d515bb3df2 100644 (file)
@@ -91,6 +91,7 @@ PACKAGECONFIG[ldconfig] = "--enable-ldconfig,--disable-ldconfig,,"
 PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
 PACKAGECONFIG[valgrind] = "ac_cv_header_valgrind_memcheck_h=yes ac_cv_header_valgrind_valgrind_h=yes ,ac_cv_header_valgrind_memcheck_h=no ac_cv_header_valgrind_valgrind_h=no ,valgrind"
 PACKAGECONFIG[qrencode] = "--enable-qrencode,--disable-qrencode,qrencode"
+PACKAGECONFIG[compat] = "--enable-compat-libs,--disable-compat-libs"
 
 CACHED_CONFIGUREVARS += "ac_cv_path_KILL=${base_bindir}/kill"
 CACHED_CONFIGUREVARS += "ac_cv_path_KMOD=${base_bindir}/kmod"