]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-firmware: Split out the QAT firmware
authorSaul Wold <sgw@linux.intel.com>
Mon, 23 Oct 2017 22:33:23 +0000 (15:33 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 20 Jan 2018 22:52:15 +0000 (22:52 +0000)
Create a new qat package for those firmware blobs

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
(cherry picked from commit b48c746736012cfd85e8263efcf125ecd17ca7bb)
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-kernel/linux-firmware/linux-firmware_git.bb

index 6f0dfad4721544a391c1ac7ca8f6348e1c11c371..37e50cbf451274c95833db8f0d72f52964060af4 100644 (file)
@@ -255,6 +255,7 @@ PACKAGES =+ "${PN}-ralink-license ${PN}-ralink \
              ${PN}-adsp-sst-license ${PN}-adsp-sst \
              ${PN}-bnx2-mips \
              ${PN}-netronome-license ${PN}-netronome \
+             ${PN}-qat ${PN}-qat-license \
              ${PN}-whence-license \
              ${PN}-license \
              "
@@ -697,6 +698,13 @@ LICENSE_${PN}-adsp-sst-license    = "Firmware-adsp_sst"
 FILES_${PN}-adsp-sst              = "${nonarch_base_libdir}/firmware/intel/dsp_fw*"
 RDEPENDS_${PN}-adsp-sst           = "${PN}-adsp-sst-license"
 
+# For QAT
+LICENSE_${PN}-qat         = "Firmware-qat"
+LICENSE_${PN}-qat-license = "Firmware-qat"
+FILES_${PN}-qat-license   = "${nonarch_base_libdir}/firmware/LICENCE.qat_firmware"
+FILES_${PN}-qat           = "${nonarch_base_libdir}/firmware/qat*.bin"
+RDEPENDS_${PN}-qat        = "${PN}-qat-license"
+
 # For other firmwares
 # Maybe split out to separate packages when needed.
 LICENSE_${PN} = "\