]> code.ossystems Code Review - openembedded-core.git/commitdiff
libopensync: make SVN version buildable (disabled by default)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 25 Apr 2007 12:39:49 +0000 (12:39 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 25 Apr 2007 12:39:49 +0000 (12:39 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1556 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/opensync/libopensync/fix-attr.patch [new file with mode: 0644]
meta/packages/opensync/libopensync/gcc.patch [new file with mode: 0644]
meta/packages/opensync/libopensync/no-werror.patch [new file with mode: 0644]
meta/packages/opensync/libopensync/zlib.patch [new file with mode: 0644]
meta/packages/opensync/libopensync_svn.bb

diff --git a/meta/packages/opensync/libopensync/fix-attr.patch b/meta/packages/opensync/libopensync/fix-attr.patch
new file mode 100644 (file)
index 0000000..7a2e544
--- /dev/null
@@ -0,0 +1,13 @@
+Index: trunk/opensync/merger/opensync_xmlfield.c
+===================================================================
+--- trunk.orig/opensync/merger/opensync_xmlfield.c     2007-04-12 16:40:07.000000000 +0200
++++ trunk/opensync/merger/opensync_xmlfield.c  2007-04-12 16:40:11.000000000 +0200
+@@ -298,7 +298,7 @@
+       int count;
+       xmlAttrPtr attr = xmlfield->node->properties;
+       
+-      for(count=0; attribute != NULL; count++) {
++      for(count=0; attr != NULL; count++) {
+               if(count == nth)
+                       return (const char *)attr->name;
+               attr = attr->next;
diff --git a/meta/packages/opensync/libopensync/gcc.patch b/meta/packages/opensync/libopensync/gcc.patch
new file mode 100644 (file)
index 0000000..3eee014
--- /dev/null
@@ -0,0 +1,29 @@
+Index: trunk/SConstruct
+===================================================================
+--- trunk.orig/SConstruct      2007-04-25 13:20:13.000000000 +0200
++++ trunk/SConstruct   2007-04-25 14:00:02.000000000 +0200
+@@ -36,7 +36,11 @@
+ opts.Add(BoolOption('enable_python', 'Build python wrapper? (swig required)', 0))
+ opts.Add(BoolOption('debug_modules', 'Should unloading of shared modules be avoided (DEBUGGING ONLY!)', 0))
+ opts.Add(BoolOption('enable_doxygen', 'Generating OpenSync API with doxygen?', 0))
+-
++opts.AddOptions(
++('CC', 'Path to Custom c compiler', 'gcc'),
++('CXX', 'Path to Custom c++ compiler flags', 'g++'),
++('LDFLAGS', 'Linker flags', ''),
++)
+ target_dir = SelectBuildDir('build')
+ sys.path.append(target_dir)
+@@ -63,6 +67,11 @@
+ env.Append(CCFLAGS = r'-DENABLE_TOOLS=$enable_tools')
+ env.Append(CCFLAGS = r'-DENABLE_PROFILING=$enable_profiling')
++env.Replace(
++       CC = env['CC'],
++       CXX = env['CXX'],
++       LDFLAGS = env['LDFLAGS']
++)
+ # pkg config files
+ subst_dict={'@prefix@': '$prefix',
diff --git a/meta/packages/opensync/libopensync/no-werror.patch b/meta/packages/opensync/libopensync/no-werror.patch
new file mode 100644 (file)
index 0000000..523ceaa
--- /dev/null
@@ -0,0 +1,13 @@
+Index: trunk/build/linux/osync_build.py
+===================================================================
+--- trunk.orig/build/linux/osync_build.py      2007-04-25 13:28:44.000000000 +0200
++++ trunk/build/linux/osync_build.py   2007-04-25 13:28:54.000000000 +0200
+@@ -48,7 +48,7 @@
+       env.ParseConfig('pkg-config --cflags --libs libxml-2.0')
+       env.ParseConfig('pkg-config --cflags --libs sqlite3')
+       env.Append(CCFLAGS = r'-I.')
+-      env.Append(CCFLAGS = [r'-Wall', r'-Werror'])
++      env.Append(CCFLAGS = [r'-Wall'])
+       
+       testenv = env.Copy()
+       testenv.Append(CCFLAGS = r'-I' + testenv.GetLaunchDir() + '/tests')
diff --git a/meta/packages/opensync/libopensync/zlib.patch b/meta/packages/opensync/libopensync/zlib.patch
new file mode 100644 (file)
index 0000000..89c10a8
--- /dev/null
@@ -0,0 +1,13 @@
+Index: trunk/opensync/SConscript
+===================================================================
+--- trunk.orig/opensync/SConscript     2007-04-25 14:08:21.000000000 +0200
++++ trunk/opensync/SConscript  2007-04-25 14:08:40.000000000 +0200
+@@ -149,6 +149,8 @@
+ gmodule-2.0
+ libxml2
+ sqlite3
++z
++m
+ """
+ libopensync = env.SharedLibrary('opensync', Split(sources), LIBS = Split(Libraries))
index ac7da051c874fa891fee2a21d7d0bdb50288510b..0fb86381e65357bf2b037912717d24d5933edad8 100644 (file)
@@ -2,17 +2,112 @@ LICENSE = "LGPL"
 HOMEPAGE = "http://www.opensync.org/"
 DEPENDS = "sqlite3 libxml2 zlib glib-2.0"
 PV = "0.22+svn${SRCDATE}"
-SRC_URI = "svn://svn.opensync.org;module=trunk;proto=http"
 
-inherit autotools pkgconfig lib_package
+SRC_URI = "svn://svn.opensync.org;module=trunk;proto=http \
+           file://fix-attr.patch;patch=1 \
+          file://gcc.patch;patch=1 \
+          file://zlib.patch;patch=1 \
+          file://no-werror.patch;patch=1"
+
+inherit scons
 
 S = "${WORKDIR}/trunk"
+
+DEFAULT_PREFERENCE = "-1"
+
 EXTRA_OECONF = "--disable-python"
 LEAD_SONAME = "libopensync.so"
 
-FILES_${PN} += " ${libdir}/opensync/formats/*.so"
+FILES_${PN} += " ${libdir}/opensync/formats/*.so ${datadir}/opensync/ ${libdir}/*.so"
+
+export HOST_SYS = "${HOST_ARCH}${HOST_VENDOR}-${HOST_OS}"
 
 do_stage() {
-       autotools_stage_all
+install -d ${STAGING_LIBDIR}/formats
+
+install -m 0644 formats/libcontact.so ${STAGING_LIBDIR}/formats/
+install -m 0644 formats/libdata.so ${STAGING_LIBDIR}/formats/
+install -m 0644 formats/libevent.so ${STAGING_LIBDIR}/formats/
+install -m 0644 formats/libfile.so ${STAGING_LIBDIR}/formats/
+install -m 0644 formats/libopensync-*format.so ${STAGING_LIBDIR}/formats/
+install -m 0644 formats/libtodo.so ${STAGING_LIBDIR}/formats/
+install -m 0644 formats/libxmlformat-*.so ${STAGING_LIBDIR}/formats/
+install -m 0644 opensync/libopensync.so ${STAGING_LIBDIR}
+
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/archive/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/data/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/engine/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/format/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/group/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/helper/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/merger/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/
+install -d ${STAGING_INCDIR}/opensync-1.0/opensync/version/
+
+install -m 0644 formats/file.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-client.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-context.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-data.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-error.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-format.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-group.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-helper.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-ipc.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync_list.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-module.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-support.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-time.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync-version.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+install -m 0644 opensync/opensync_xml.h ${STAGING_INCDIR}/opensync-1.0/opensync/
+
+install -m 0644 opensync/archive/opensync_archive.h ${STAGING_INCDIR}/opensync-1.0/opensync/archive/
+install -m 0644 opensync/data/opensync_change.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/
+install -m 0644 opensync/data/opensync_data.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/
+install -m 0644 opensync/engine/opensync_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/
+install -m 0644 opensync/engine/opensync_obj_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/
+install -m 0644 opensync/engine/opensync_status.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/
+install -m 0644 opensync/format/opensync_converter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/
+install -m 0644 opensync/format/opensync_filter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/
+install -m 0644 opensync/format/opensync_format_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/
+install -m 0644 opensync/format/opensync_objformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/
+install -m 0644 opensync/format/opensync_time.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/
+install -m 0644 opensync/group/opensync_group_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/
+install -m 0644 opensync/group/opensync_group.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/
+install -m 0644 opensync/group/opensync_member.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/
+install -m 0644 opensync/helper/opensync_anchor.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/
+install -m 0644 opensync/helper/opensync_hashtable.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/
+install -m 0644 opensync/ipc/opensync_message.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/
+install -m 0644 opensync/ipc/opensync_queue.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/
+install -m 0644 opensync/ipc/opensync_serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/
+install -m 0644 opensync/mapping/opensync_mapping_entry.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/
+install -m 0644 opensync/mapping/opensync_mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/
+install -m 0644 opensync/mapping/opensync_mapping_table.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/
+install -m 0644 opensync/mapping/opensync_mapping_view.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/
+install -m 0644 opensync/merger/opensync_capabilities.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/
+install -m 0644 opensync/merger/opensync_capability.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/
+install -m 0644 opensync/merger/opensync_merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/
+install -m 0644 opensync/merger/opensync_xmlfield.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/
+install -m 0644 opensync/merger/opensync_xmlfieldlist.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/
+install -m 0644 opensync/merger/opensync_xmlformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/
+install -m 0644 opensync/plugin/opensync_plugin_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/
+install -m 0644 opensync/plugin/opensync_plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/
+install -m 0644 opensync/plugin/opensync_plugin_info.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/
+install -m 0644 opensync/plugin/opensync_sink.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/
+install -m 0644 opensync/version/opensync_version.h ${STAGING_INCDIR}/opensync-1.0/opensync/version/
+
+cat ${S}/opensync-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:"  -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/opensync-1.0.pc
+cat ${S}/osengine-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:"  -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/osengine-1.0.pc
+
 }
 
+do_install_prepend() {
+    install -d ${D}${libdir}
+}