]> code.ossystems Code Review - openembedded-core.git/commitdiff
Revert "ncurses: fix incorrect UPSTREAM_CHECK_GITTAGREGEX"
authorAlexander Kanavin <alex.kanavin@gmail.com>
Fri, 31 May 2019 20:27:10 +0000 (22:27 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 1 Jun 2019 10:26:56 +0000 (11:26 +0100)
This reverts commit 91227184b59df30222e45abf2edf13e4e65164a1.

Instead of fixing incorrect regex, the commit actually broke the correct one.

Before the reverted commit:
alexander@alexander-box:~/development/poky$ devtool check-upgrade-status ncurses
INFO: ncurses                   6.1             6.1+20181013    Hongxu Jia <hongxu.jia@windriver.com> 7a97a7f937762ba342d5b2fd7cd090885a809835

After the reverted commit:
alexander@alexander-box:~/development/poky$ devtool check-upgrade-status ncurses
INFO: ncurses                   6.1             UNKNOWN_BROKEN  Hongxu Jia <hongxu.jia@windriver.com>

The code in bitbake/lib/bb/fetch2/git.py actually splits each tag
with '/' as separator and takes only the last part for some reason,
so the "debian/" or "upstream/" prefixes are never a part of the string
that is matched against regex:
https://salsa.debian.org/debian/ncurses/tags

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/ncurses/ncurses_6.1+20181013.bb

index 928c47742ce8261df8b8c19ac640e9626be4dacd..ef6ca9879bce5c75a2431afadbf9549dae77b940 100644 (file)
@@ -8,4 +8,4 @@ SRC_URI += "file://0001-tic-hang.patch \
 SRCREV = "7a97a7f937762ba342d5b2fd7cd090885a809835"
 S = "${WORKDIR}/git"
 EXTRA_OECONF += "--with-abi-version=5 --cache-file=${B}/config.cache"
-UPSTREAM_CHECK_GITTAGREGEX = "upstream/(?P<pver>\d+(\.\d+)+(\+\d+)*)"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+(\+\d+)*)"