]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: upgrade 21.1.3 -> 21.1.4
authorAndreas Müller <schnitzeltony@gmail.com>
Mon, 5 Jul 2021 18:42:58 +0000 (20:42 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Jul 2021 10:38:57 +0000 (11:38 +0100)
Bug fixes
    * [anv] GravityMark (benchmark) crashes on ANV
    * [opengl] We happy few not being rendered correctly
    * Factorio: GPU hang when opening machine inventory
    * RuneScape on Mesa 21.1.1 (VEGA10) has bad performance and leaks memory
    * Supraland: flickering black bars on ground
    * radv: GPU hang in Cyberpunk 2077 on Big Navi
    * [amdgpu][renoir][rx5500m]: [drm:0xffffffff8198ad5e] *ERROR* ring gfx timeout, signaled seq=10952, emitted seq=10954
    * [spirv-fuzz] SPIR-V parsing FAILED: Invalid back or cross-edge in the CFG
    * panfrost Mount and Blade: Warband (glitches)
    * anv: dEQP-VK.robustness.robustness2*no_fmt_qual.null_descriptor.samples* fail

Changes
    * util/fossilize_db: Pull seek into lock.
    * util/fossilize_db: Split out reading the index.
    * util/fossilize_db: Do not lock the fossilize db permanently.
    * spirv: Fix handling of OpBranchConditional with same THEN and ELSE
    * nir/opt_if: Don’t split ALU for single block infinite loops
    * llvmpipe: Add handle export for resource_get_param
    * i965: fix regression in pipe control on g45
    * pick_status.json: Update to 977355c6e5efd781dde85d834172dd23cd4852f1
    * pick_status.json: Update to 40b67a292297606f0a7576e3ef4087028d5edd17
    * zink: do not unmap dt-buffers twice
    * zink: drop repeated usage-bit
    * zink: do not check buffer-format for usage-bits
    * zink: remove unused moltenvk functions
    * libgl-gdi: add missing include
    * aux/trace: fix bool argument
    * ci/windows: work around meson encoding issues
    * intel/fs: Teach IR about EOT instruction writing the accumulator implicitly on TGL+.
    * intel/fs: Fix synchronization of accumulator-clearing W/A move on TGL+.
    * pan/mdg: Add a bundle ID to instructions
    * pan/mdg: Reorder some code in mir_spill_register
    * pan/mdg: Fill from TLS before spilling non-SSA nodes
    * pan/mdg: Fix reading a spilt register in the bundle it’s written
    * pan/mdg: Add 16 bytes of padding to the end of shaders
    * intel/nir: Fix txs for null surfaces
    * spirv: Create acceleration structure and shader record variables
    * nv50/ir: fix surface lowering when values get shared accross operations
    * anv: Fix dynamic primitive topology for tess on Gfx7.x too
    * anv: allocate bigger batches as we grow command buffers
    * mesa: unreference zombie buffers when creating buffers to lower memory usage
    * compiler/glsl: Use mutex lock while freeing up mem_ctx
    * anv: fix dynamic primitive topology for tess
    * zink: handle custom border color without matching wrap mode case
    * radeonsi: skip instance_count==0 draws on <= GFX9
    * radeonsi: disable ngg culling on llvm < 12
    * radv: reject binding buffer/image when the device memory is too small
    * radv: always decompress both aspects of a depth/stencil image
    * amd/addrlib: remove Meson debug message()
    * radeon/vcn/enc: Add missing line to HEVC SPS header code
    * util: add work around for the game We Happy Few
    * ac/nir: Update TCS output barriers with nir_var_mem_shared.
    * radv/llvm: Emit s_barrier at the beginning of NGG non-GS shaders.
    * aco/gfx10: NGG zero output workaround for conservative rasterization.
    * aco/gfx10: Emit barrier at the start of NGG VS and TES.

Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa-gl_21.1.4.bb [moved from meta/recipes-graphics/mesa/mesa-gl_21.1.3.bb with 100% similarity]
meta/recipes-graphics/mesa/mesa.inc
meta/recipes-graphics/mesa/mesa_21.1.4.bb [moved from meta/recipes-graphics/mesa/mesa_21.1.3.bb with 100% similarity]

index b7e42a9d7f622a16edbbd88939d03fbd21795953..6a102585a13d1c9446613c9044df4d7db1566297 100644 (file)
@@ -21,7 +21,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
            file://0001-futex.h-Define-__NR_futex-if-it-does-not-exist.patch \
            "
 
-SRC_URI[sha256sum] = "cbe221282670875ffd762247b6a2c95dcee91d0a34c29802c75ef761fc891e69"
+SRC_URI[sha256sum] = "1f177f44098164b65731c5ded4c928fd58b14f6c9d2087aa0e37bc79bf79e90b"
 
 UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"