]> code.ossystems Code Review - openembedded-core.git/commitdiff
ptest-runner: libgcc must be installed for pthread_cancel to work
authorJose Quaresma <quaresma.jose@gmail.com>
Mon, 3 May 2021 17:10:40 +0000 (18:10 +0100)
committerSteve Sakoman <steve@sakoman.com>
Fri, 7 May 2021 15:21:22 +0000 (05:21 -1000)
This only affects glibc systems and have been
found on runqemu core-image-minimal with gstreamer ptest-runner

STOP: ptest-runner
libgcc_s.so.1 must be installed for pthread_cancel to work
Aborted

Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 1cb679e6a4528a2cef16f65342d5e65adb14cb16)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb

index 8b9938f572bf75ebb79af1ba15907623b6c320dd..7290dc90e53707e7c3c189024081bbd9a9da6c9d 100644 (file)
@@ -27,3 +27,5 @@ do_compile () {
 do_install () {
        install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
 }
+
+RDEPENDS_${PN}_append_libc-glibc = " libgcc"