]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: Fix build on musl
authorKhem Raj <raj.khem@gmail.com>
Fri, 26 Feb 2016 06:48:00 +0000 (06:48 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 28 Feb 2016 11:32:41 +0000 (11:32 +0000)
It assumes __GLIBC__ where it could actually check for linux
and include non-glibc C library implementations like musl which
provide __BYTE_ORDER macros as well when computing system endianness

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/mesa/files/replace_glibc_check_with_linux.patch [new file with mode: 0644]
meta/recipes-graphics/mesa/mesa_11.1.1.bb

diff --git a/meta/recipes-graphics/mesa/files/replace_glibc_check_with_linux.patch b/meta/recipes-graphics/mesa/files/replace_glibc_check_with_linux.patch
new file mode 100644 (file)
index 0000000..e4461ef
--- /dev/null
@@ -0,0 +1,17 @@
+endianness check is OS wide and not specific to libc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+Index: mesa-11.1.1/src/gallium/include/pipe/p_config.h
+===================================================================
+--- mesa-11.1.1.orig/src/gallium/include/pipe/p_config.h
++++ mesa-11.1.1/src/gallium/include/pipe/p_config.h
+@@ -130,7 +130,7 @@
+  * Endian detection.
+  */
+-#ifdef __GLIBC__
++#if defined(__linux__)
+ #include <endian.h>
+ #if __BYTE_ORDER == __LITTLE_ENDIAN
index 5d73feb5fb222dddab449850b5389e87e82e8d78..502afcfd8a7d296df5ca62993780e842c66ff8db 100644 (file)
@@ -1,6 +1,8 @@
 require ${BPN}.inc
 
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz"
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz \
+           file://replace_glibc_check_with_linux.patch \
+"
 
 SRC_URI[md5sum] = "1043dfb907beecb2a761272455960427"
 SRC_URI[sha256sum] = "64db074fc514136b5fb3890111f0d50604db52f0b1e94ba3fcb0fe8668a7fd20"