]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsb: Create ${base_prefix}/lib64 correctly when needed
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Tue, 28 Mar 2017 12:01:18 +0000 (14:01 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 31 Mar 2017 11:27:03 +0000 (12:27 +0100)
There were two remaining cases that could end up creating /lib64
rather than ${base_prefix}/lib64. The difference matters when building
with usrmerge.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lsb/lsb_4.1.bb

index 2eb67b8c3a35b22f98485e8ea42a3603ee4ffdf2..cedf39eb65792d51911cf46f5f71a1d36125088e 100644 (file)
@@ -97,8 +97,8 @@ do_install_append() {
        ln -sf ${sbindir}/chkconfig ${D}${nonarch_libdir}/lsb/remove_initd
 
        if [ "${TARGET_ARCH}" = "x86_64" ]; then
-               if [ "${baselib}" != "lib64" ]; then
-                   lnr ${D}${base_libdir} ${D}/lib64
+               if [ "${base_libdir}" != "${base_prefix}/lib64" ]; then
+                   lnr ${D}${base_libdir} ${D}${base_prefix}/lib64
                fi
               cd ${D}${base_libdir}
                ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2
@@ -111,8 +111,8 @@ do_install_append() {
        fi
 
        if [ "${TARGET_ARCH}" = "powerpc64" ]; then
-               if [ "${baselib}" != "lib64" ]; then
-                   lnr  ${D}${base_libdir} ${D}/lib64
+               if [ "${base_libdir}" != "${base_prefix}/lib64" ]; then
+                   lnr ${D}${base_libdir} ${D}${base_prefix}/lib64
                fi
                cd ${D}${base_libdir}
                ln -sf ld64.so.1 ld-lsb-ppc64.so.2
@@ -125,7 +125,7 @@ do_install_append() {
        fi
 }
 
-FILES_${PN} += "${@'/lib64' if d.getVar('TARGET_ARCH')  == ('x86_64' or 'powerpc64') and '${baselib}' != 'lib64' else ''} \
+FILES_${PN} += "${@'${base_prefix}/lib64' if d.getVar('TARGET_ARCH') == ('x86_64' or 'powerpc64') and '${base_libdir}' != '${base_prefix}/lib64' else ''} \
                 ${base_libdir} \
                 ${nonarch_libdir}/lsb \
                 ${nonarch_base_libdir}/lsb/* \