]> code.ossystems Code Review - openembedded-core.git/commitdiff
elfutils: fix elf_cvt_gnuhash
authorRoy Li <rongqing.li@windriver.com>
Tue, 28 Oct 2014 05:09:41 +0000 (13:09 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 30 Oct 2014 13:12:58 +0000 (13:12 +0000)
The 'dest' and 'src' can be same, we need to save the value of src32[2]
before swaping it.

Signed-off-by: Roy Li <rongqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/elfutils/elfutils/Fix_elf_cvt_gunhash.patch [new file with mode: 0644]
meta/recipes-devtools/elfutils/elfutils_0.148.bb
meta/recipes-devtools/elfutils/elfutils_0.158.bb

diff --git a/meta/recipes-devtools/elfutils/elfutils/Fix_elf_cvt_gunhash.patch b/meta/recipes-devtools/elfutils/elfutils/Fix_elf_cvt_gunhash.patch
new file mode 100644 (file)
index 0000000..374cba5
--- /dev/null
@@ -0,0 +1,29 @@
+Fix elf_cvt_gunhash if dest and src are same.
+
+Upstream-status: Pending
+
+The 'dest' and 'src' can be same, we need to save the value of src32[2]
+before swaping it.
+
+Signed-off-by: Baoshan Pang <BaoShan.Pang@windriver.com>
+diff --git a/libelf/gnuhash_xlate.h b/libelf/gnuhash_xlate.h
+index 6faf113..04d9ca1 100644
+--- a/libelf/gnuhash_xlate.h
++++ b/libelf/gnuhash_xlate.h
+@@ -40,6 +40,7 @@ elf_cvt_gnuhash (void *dest, const void *src, size_t len, int encode)
+      words.  We must detangle them here.   */
+   Elf32_Word *dest32 = dest;
+   const Elf32_Word *src32 = src;
++  Elf32_Word save_src32_2 = src32[2]; // dest could be equal to src
+   /* First four control words, 32 bits.  */
+   for (unsigned int cnt = 0; cnt < 4; ++cnt)
+@@ -50,7 +51,7 @@ elf_cvt_gnuhash (void *dest, const void *src, size_t len, int encode)
+       len -= 4;
+     }
+-  Elf32_Word bitmask_words = encode ? src32[2] : dest32[2];
++  Elf32_Word bitmask_words = encode ? save_src32_2 : dest32[2];
+   /* Now the 64 bit words.  */
+   Elf64_Xword *dest64 = (Elf64_Xword *) &dest32[4];
index 110624297eba5be23970395f4fad05da7e3b8221..ab956390b38bf57377676825d74d8317e2f02c02 100644 (file)
@@ -32,6 +32,7 @@ SRC_URI += "\
        file://dso-link-change.patch \
        file://nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch \
        file://elfutils-ar-c-fix-num-passed-to-memset.patch \
+       file://Fix_elf_cvt_gunhash.patch \
 "
 # Only apply when building uclibc based target recipe
 SRC_URI_append_libc-uclibc = " file://uclibc-support.patch"
index ef3dd0bb4026bf3fb745b17784de8d81c38434ed..42724a15903eecd04563825cec62191cf42f90ef 100644 (file)
@@ -30,6 +30,7 @@ SRC_URI += "\
         file://dso-link-change.patch \
         file://m4-biarch.m4-tweak-AC_RUN_IFELSE-for-cross-compiling.patch \
         file://fixheadercheck.patch \
+        file://Fix_elf_cvt_gunhash.patch \
 "
 
 # Only apply when building uclibc based target recipe