]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/3.8: qemumips graphical boot
authorBruce Ashfield <bruce.ashfield@windriver.com>
Wed, 10 Apr 2013 16:48:16 +0000 (16:48 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Apr 2013 17:00:29 +0000 (18:00 +0100)
Updating the meta SRCREV to fix and illegal instruction that is seen
when launching X with USB pointing devices.

    meta/qemumips: build USB_UHCI_HCD into the kernel

    When booting qemumips and USB_UHCI_HCD built as a module, the following
    trace is seen, and then prevents X from starting:

       qemumips user.warn kernel: Call Trace:
       qemumips user.warn kernel: [<c0028000>] uhci_check_bandwidth+0x0/0x160 [uhci_hcd]
       qemumips user.warn kernel: [<c002e08c>] uhci_urb_enqueue+0xba4/0xc48 [uhci_hcd]
       qemumips user.warn kernel: [<8058092c>] usb_hcd_submit_urb+0xdc/0x848
       qemumips user.warn kernel: [<805b8fbc>] wacom_open+0x44/0x8c
       qemumips user.warn kernel: [<805a1990>] input_open_device+0xac/0xec
       qemumips user.warn kernel: [<805a8cec>] evdev_open+0x188/0x1bc
       qemumips user.warn kernel: [<802331d8>] chrdev_open+0xc8/0x1c4
       qemumips user.warn kernel: [<8022b338>] do_dentry_open+0x248/0x2e4
       qemumips user.warn kernel: [<8022b418>] finish_open+0x44/0x68
       qemumips user.warn kernel: [<8023e51c>] do_last.isra.29+0x2c0/0xcbc
       qemumips user.warn kernel: [<8023efd8>] path_openat+0xc0/0x52c
       qemumips user.warn kernel: [<8023f840>] do_filp_open+0x4c/0xbc
       qemumips user.warn kernel: [<8022cc3c>] do_sys_open+0x128/0x20c
       qemumips user.warn kernel: [<8010c07c>] stack_done+0x20/0x44
       qemumips user.warn kernel: Code: (Bad address in epc)
       qemumips user.warn kernel: ---[ end trace 8a48c6046870f8c2 ]---

    Building the module into the kernel fixes the problem, but the root
    cause is still under investigation. The pipelines around jumps to
    module addresses seem to be triggering invalid instructions.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_3.8.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb
meta/recipes-kernel/linux/linux-yocto_3.8.bb

index 1929796566ede4293250421c061ed30eff02c218..05d497f276c597054a67126ce8ddd2b8db448f28 100644 (file)
@@ -10,7 +10,7 @@ KMETA = "meta"
 
 SRCREV_machine ?= "0f7d294a9d07713059af345188f9cd4f549b4e77"
 SRCREV_machine_qemuppc ?= "82cdb00523b3f86219706d9f12dc80ff8d1c747a"
-SRCREV_meta ?= "4c567e02266ebe383abc6755b4f7908696ac099d"
+SRCREV_meta ?= "1b94482e3ab8f7e495ee4d6971e13cdad1990e8e"
 
 PR = "${INC_PR}.0"
 PV = "${LINUX_VERSION}+git${SRCPV}"
index b6d112c24c4e29b382daec59f70a9d1821ecdd19..8bd4a0e8bd846d82e1336a1734752941a9e9fa1d 100644 (file)
@@ -13,7 +13,7 @@ LINUX_VERSION ?= "3.8.4"
 KMETA = "meta"
 
 SRCREV_machine ?= "11998bd1f44b21cd0b8c0ca11cbd36865f14bfdc"
-SRCREV_meta ?= "4c567e02266ebe383abc6755b4f7908696ac099d"
+SRCREV_meta ?= "1b94482e3ab8f7e495ee4d6971e13cdad1990e8e"
 
 PR = "${INC_PR}.0"
 PV = "${LINUX_VERSION}+git${SRCPV}"
index ddafd26f9041a0c976ab16419f744148e2df9d34..c861b99c2f1dce34433dd4b00097226451bfb188 100644 (file)
@@ -9,7 +9,7 @@ SRCREV_machine_qemuppc ?= "223428bbc1a355200bd9a8046fd272c1b9b13e67"
 SRCREV_machine_qemux86 ?= "11998bd1f44b21cd0b8c0ca11cbd36865f14bfdc"
 SRCREV_machine_qemux86-64 ?= "11998bd1f44b21cd0b8c0ca11cbd36865f14bfdc"
 SRCREV_machine ?= "11998bd1f44b21cd0b8c0ca11cbd36865f14bfdc"
-SRCREV_meta ?= "4c567e02266ebe383abc6755b4f7908696ac099d"
+SRCREV_meta ?= "1b94482e3ab8f7e495ee4d6971e13cdad1990e8e"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"