]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-git: Upgrade from 1.0.2 to 2.0.5
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>
Wed, 8 Jun 2016 05:56:09 +0000 (05:56 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Jun 2016 22:36:53 +0000 (23:36 +0100)
Move checksums into the relevant recipes as currently python-git and python3-git
are at different versions - RB.

Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python-git.inc
meta/recipes-devtools/python/python-git_2.0.5.bb [moved from meta/recipes-devtools/python/python-git_1.0.2.bb with 60% similarity]
meta/recipes-devtools/python/python3-git_1.0.2.bb

index 72632b7a8ce015613e3cb75a4ae7b71d3b1f4078..4cb53e789e904760a341f3d462f53e96658fbd8f 100644 (file)
@@ -8,10 +8,7 @@ SECTION = "devel/python"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
 
-SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "d92d96a8da0fc77cf141d3e16084e094"
-SRC_URI[sha256sum] = "85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84"
+SRC_URI = "https://files.pythonhosted.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
 
 UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/GitPython/"
 UPSTREAM_CHECK_REGEX = "/GitPython/(?P<pver>(\d+[\.\-_]*)+)"
similarity index 60%
rename from meta/recipes-devtools/python/python-git_1.0.2.bb
rename to meta/recipes-devtools/python/python-git_2.0.5.bb
index 5ca7713dc91753bdc9579c30eab37de4b6b989e9..de4c76ed1ae43d273176fdde0625c5f39c6026af 100644 (file)
@@ -1,8 +1,10 @@
 require python-git.inc
 
+SRC_URI[md5sum] = "f4f60f269fb5f6a332c653a5bc015239"
+SRC_URI[sha256sum] = "20f3c90fb8a11edc52d363364fb0a116a410c7b7bdee24a433712b5413d1028e"
+
 DEPENDS = "python-gitdb"
 
 inherit setuptools
 
 RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold python-unixadmin"
-
index 6620444a863b194a12aa0c1679d60aaa6d42d5a7..034708e85136ae745c1e03b5d783d8583461f75d 100644 (file)
@@ -1,5 +1,8 @@
 require python-git.inc
 
+SRC_URI[md5sum] = "d92d96a8da0fc77cf141d3e16084e094"
+SRC_URI[sha256sum] = "85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84"
+
 DEPENDS = "python3-gitdb"
 
 inherit setuptools3