]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: add wrapper for debugedit executable
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Tue, 2 Jul 2013 12:17:18 +0000 (13:17 +0100)
committerSaul Wold <sgw@linux.intel.com>
Tue, 2 Jul 2013 14:58:10 +0000 (07:58 -0700)
This should fix sstate relocation issues with debugedit failing during
do_package on the Yocto Project autobuilder.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/rpm/rpm_5.4.9.bb

index 0dd5806026b15f2f35574f907704b7295b5b1337..3f4854eb6ac9fdba6f99ea952a24e47b0207ea98 100644 (file)
@@ -472,7 +472,7 @@ do_install_append_class-native() {
                RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
                RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
 
-       for rpm_binary in ${D}/${libdir}/rpm/bin/rpm*; do
+       for rpm_binary in ${D}/${libdir}/rpm/bin/rpm* ${D}/${libdir}/rpm/bin/debugedit; do
                create_wrapper $rpm_binary \
                        RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
                        RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \