]> code.ossystems Code Review - openembedded-core.git/commitdiff
image.bbclass: run wicenv task only for wic images
authorEd Bartosh <ed.bartosh@linux.intel.com>
Wed, 23 Mar 2016 09:09:18 +0000 (11:09 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 28 Mar 2016 14:54:51 +0000 (15:54 +0100)
Currently do_wicenv task is run for all images. However, its
result is used only to produce wic image. It's better to
run this task only for wic images. If another rootfs is
required to produce wic image, dependency to its do_wicenv
must be added to the wic image recipy.

Stopped running do_wicenv for all images. Added explicit
dependency to this task in wic-image-minimal recipe.

[YOCTO #9095]

Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta-selftest/recipes-test/images/wic-image-minimal.bb
meta/classes/image.bbclass

index 9c50ddbbf52de83b50d6e7b890fb0fa82a284191..a294ba7af4e108403a261e0f4496e0f7302b52c3 100644 (file)
@@ -11,7 +11,7 @@ DEPENDS = "syslinux syslinux-native parted-native dosfstools-native mtools-nativ
 
 # core-image-minimal is referenced in .wks, so we need its rootfs
 # to be ready before our rootfs
-do_rootfs[depends] += "core-image-minimal:do_rootfs_wicenv"
+do_rootfs[depends] += "core-image-minimal:do_image core-image-minimal:do_rootfs_wicenv"
 
 IMAGE_ROOTFS_EXTRA_SPACE = "2000"
 
index 0249f77bcfefbf97afb6bacbcd2a86118ccb4d40..62ff07e2e77ecd68f3b8a40995d6ce57e66158e4 100644 (file)
@@ -275,7 +275,7 @@ python do_rootfs_wicenv () {
             if value:
                 envf.write('%s="%s"\n' % (var, value.strip()))
 }
-addtask do_rootfs_wicenv after do_image before do_image_wic do_image_complete
+addtask do_rootfs_wicenv after do_image before do_image_wic
 do_rootfs_wicenv[vardeps] += "${WICVARS}"
 do_rootfs_wicenv[prefuncs] = 'set_image_size'