]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: v5.3+ build fixes
authorBruce Ashfield <bruce.ashfield@gmail.com>
Wed, 28 Aug 2019 19:28:40 +0000 (15:28 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 30 Aug 2019 16:10:23 +0000 (17:10 +0100)
In the 5.3+ perf builds, there are multiple unistd.h files that need
to be kept in sync. So not only do we update one, we update both to
ensure that libc-headers and the perf build are in sync.

perf checks some key files itself to be sure they are in sync, and
bits.h can be out of sync. There's no build error that results with
bits.h at the moment, but we still make sure they are in sync to
avoid the configure/compile warning.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index af0410c88d005d4778e1a55e0a90eee517e744be..7f00df0f8e6690146ee5ae3eafebb53886f87baa 100644 (file)
@@ -242,6 +242,10 @@ do_configure_prepend () {
     # unistd.h can be out of sync between libc-headers and the captured version in the perf source
     # so we copy it from the sysroot unistd.h to the perf unistd.h
     install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
+    install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
+
+    # bits.h can have the same issuen as unistd.h, so we make the tools variant take precedence
+    install -D -m0644 ${S}/tools/include/linux/bits.h ${S}/include/linux/bits.h
 }
 
 python do_package_prepend() {