]> code.ossystems Code Review - openembedded-core.git/commitdiff
iptables: new package 1.4.8
authorKevin Tian <kevin.tian@intel.com>
Fri, 30 Jul 2010 01:21:49 +0000 (09:21 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 30 Jul 2010 13:50:31 +0000 (14:50 +0100)
Create a new recipe based on openembedded 1.4.7 with cleanup suitable
for poky acceptance.

The tricky thing is to figure out which set of kernel modules are
recommended for a basic iptable functions

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta-lsb/packages/iptables/iptables_1.4.8.bb [new file with mode: 0644]

diff --git a/meta-lsb/packages/iptables/iptables_1.4.8.bb b/meta-lsb/packages/iptables/iptables_1.4.8.bb
new file mode 100644 (file)
index 0000000..ad707d3
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "iptables is the userspace command line program used to configure the Linux 2.4.x and 2.6.x IPv4 packet filtering ruleset"
+HOMEPAGE = "http://www.netfilter.org/"
+BUGTRACKER = "http://bugzilla.netfilter.org/"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
+                    file://iptables.c;firstline=13;endline=25;md5=f1028f2401da1c120df27594b2be50ef"
+
+PR = "r0"
+
+RRECOMMENDS_${PN} = "kernel-module-x-tables \
+                     kernel-module-ip-tables \
+                     kernel-module-iptable-filter \
+                     kernel-module-iptable-nat \
+                     kernel-module-nf-defrag-ipv4 \
+                     kernel-module-nf-conntrack \
+                     kernel-module-nf-conntrack-ipv4 \
+                     kernel-module-nf-nat \
+                     kernel-module-ipt-masquerade"
+FILES_${PN}-dbg =+ "${libexecdir}/xtables/.debug"
+
+SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
+                ${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6', d)}"
+
+do_configure_prepend() {
+       # they are all libtool m4 files
+       rm -rf ${S}/m4
+}