]> code.ossystems Code Review - openembedded-core.git/commitdiff
uclibc: Cleanup the machine dependent config files
authorKhem Raj <raj.khem@gmail.com>
Sat, 11 Jun 2011 09:09:00 +0000 (02:09 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Jun 2011 12:15:52 +0000 (13:15 +0100)
We only have arch specific machine fragments now.
Introduce use of KCONFIG_ALLCONFIG and use allnoconfig

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-core/uclibc/uclibc-git/armv5te/uClibc.machine
meta/recipes-core/uclibc/uclibc-git/armv5teb/uClibc.machine [moved from meta/recipes-core/uclibc/uclibc-git/nslu2be/uClibc.machine with 100% similarity]
meta/recipes-core/uclibc/uclibc-git/efika/uClibc.machine [deleted file]
meta/recipes-core/uclibc/uclibc-git/mips/uClibc.machine [moved from meta/recipes-core/uclibc/uclibc-git/qemumips/uClibc.machine with 100% similarity]
meta/recipes-core/uclibc/uclibc-git/qemuarm/uClibc.machine [deleted file]
meta/recipes-core/uclibc/uclibc-git/qemux86/uClibc.machine [deleted file]
meta/recipes-core/uclibc/uclibc-git/uClibc.config [deleted file]
meta/recipes-core/uclibc/uclibc-git/uClibc.distro
meta/recipes-core/uclibc/uclibc.inc
meta/recipes-core/uclibc/uclibc_git.bb

index b012a38c94b6a175102558fe1eea6a6f4edd4fac..2242dc94d6739051b67c7b4c1aac51b42b42352d 100644 (file)
@@ -38,14 +38,14 @@ FORCE_OPTIONS_FOR_ARCH=y
 CONFIG_ARM_EABI=y
 # COMPILE_IN_THUMB_MODE is not set
 USE_BX=y
-CONFIG_GENERIC_ARM=y
+# CONFIG_GENERIC_ARM is not set
 # CONFIG_ARM610 is not set
 # CONFIG_ARM710 is not set
 # CONFIG_ARM7TDMI is not set
 # CONFIG_ARM720T is not set
 # CONFIG_ARM920T is not set
 # CONFIG_ARM922T is not set
-# CONFIG_ARM926T is not set
+CONFIG_ARM926T=y
 # CONFIG_ARM10T is not set
 # CONFIG_ARM1136JF_S is not set
 # CONFIG_ARM1176JZ_S is not set
diff --git a/meta/recipes-core/uclibc/uclibc-git/efika/uClibc.machine b/meta/recipes-core/uclibc/uclibc-git/efika/uClibc.machine
deleted file mode 100644 (file)
index 5ed7b51..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-#
-# Automatically generated make config: don't edit
-# Wed Dec 20 11:05:48 2006
-#
-# TARGET_alpha is not set
-# TARGET_arm is not set
-# TARGET_bfin is not set
-# TARGET_cris is not set
-# TARGET_e1 is not set
-# TARGET_frv is not set
-# TARGET_h8300 is not set
-# TARGET_hppa is not set
-# TARGET_i386 is not set
-# TARGET_i960 is not set
-# TARGET_ia64 is not set
-# TARGET_m68k is not set
-# TARGET_microblaze is not set
-# TARGET_mips is not set
-# TARGET_nios is not set
-# TARGET_nios2 is not set
-TARGET_powerpc=y
-# TARGET_sh is not set
-# TARGET_sh64 is not set
-# TARGET_sparc is not set
-# TARGET_v850 is not set
-# TARGET_vax is not set
-# TARGET_x86_64 is not set
-
-#
-# Target Architecture Features and Options
-#
-TARGET_ARCH="powerpc"
-FORCE_OPTIONS_FOR_ARCH=y
-ARCH_BIG_ENDIAN=y
-
-#
-# Using Big Endian
-#
-ARCH_HAS_MMU=y
-ARCH_USE_MMU=y
-UCLIBC_HAS_FLOATS=y
-UCLIBC_HAS_FPU=y
-DO_C99_MATH=y
-KERNEL_HEADERS="<path/to/kernel/headers>" 
-HAVE_DOT_CONFIG=y
diff --git a/meta/recipes-core/uclibc/uclibc-git/qemuarm/uClibc.machine b/meta/recipes-core/uclibc/uclibc-git/qemuarm/uClibc.machine
deleted file mode 100644 (file)
index 2242dc9..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-#
-# Automatically generated make config: don't edit
-# Version: 0.9.32-git
-# Mon Jul 19 01:34:29 2010
-#
-# TARGET_alpha is not set
-TARGET_arm=y
-# TARGET_avr32 is not set
-# TARGET_bfin is not set
-# TARGET_cris is not set
-# TARGET_e1 is not set
-# TARGET_frv is not set
-# TARGET_h8300 is not set
-# TARGET_hppa is not set
-# TARGET_i386 is not set
-# TARGET_i960 is not set
-# TARGET_ia64 is not set
-# TARGET_m68k is not set
-# TARGET_microblaze is not set
-# TARGET_mips is not set
-# TARGET_nios is not set
-# TARGET_nios2 is not set
-# TARGET_powerpc is not set
-# TARGET_sh is not set
-# TARGET_sh64 is not set
-# TARGET_sparc is not set
-# TARGET_v850 is not set
-# TARGET_vax is not set
-# TARGET_x86_64 is not set
-# TARGET_xtensa is not set
-
-#
-# Target Architecture Features and Options
-#
-TARGET_ARCH="arm"
-FORCE_OPTIONS_FOR_ARCH=y
-# CONFIG_ARM_OABI is not set
-CONFIG_ARM_EABI=y
-# COMPILE_IN_THUMB_MODE is not set
-USE_BX=y
-# CONFIG_GENERIC_ARM is not set
-# CONFIG_ARM610 is not set
-# CONFIG_ARM710 is not set
-# CONFIG_ARM7TDMI is not set
-# CONFIG_ARM720T is not set
-# CONFIG_ARM920T is not set
-# CONFIG_ARM922T is not set
-CONFIG_ARM926T=y
-# CONFIG_ARM10T is not set
-# CONFIG_ARM1136JF_S is not set
-# CONFIG_ARM1176JZ_S is not set
-# CONFIG_ARM1176JZF_S is not set
-# CONFIG_ARM_CORTEX_M3 is not set
-# CONFIG_ARM_CORTEX_M1 is not set
-# CONFIG_ARM_SA110 is not set
-# CONFIG_ARM_SA1100 is not set
-# CONFIG_ARM_XSCALE is not set
-# CONFIG_ARM_IWMMXT is not set
-TARGET_SUBARCH=""
-
-#
-# Using ELF file format
-#
-ARCH_ANY_ENDIAN=y
-ARCH_LITTLE_ENDIAN=y
-# ARCH_WANTS_BIG_ENDIAN is not set
-ARCH_WANTS_LITTLE_ENDIAN=y
-ARCH_HAS_MMU=y
-ARCH_USE_MMU=y
-UCLIBC_HAS_FLOATS=y
-# UCLIBC_HAS_FPU is not set
-UCLIBC_HAS_SOFT_FLOAT=y
-DO_C99_MATH=y
-# DO_XSI_MATH is not set
-# UCLIBC_HAS_FENV is not set
-KERNEL_HEADERS="/usr/include"
-HAVE_DOT_CONFIG=y
diff --git a/meta/recipes-core/uclibc/uclibc-git/qemux86/uClibc.machine b/meta/recipes-core/uclibc/uclibc-git/qemux86/uClibc.machine
deleted file mode 100644 (file)
index 3909ccc..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Automatically generated make config: don't edit
-#
-# TARGET_alpha is not set
-# TARGET_arm is not set
-# TARGET_bfin is not set
-# TARGET_cris is not set
-# TARGET_e1 is not set
-# TARGET_frv is not set
-# TARGET_h8300 is not set
-# TARGET_hppa is not set
-TARGET_i386=y
-# TARGET_i960 is not set
-# TARGET_m68k is not set
-# TARGET_microblaze is not set
-# TARGET_mips is not set
-# TARGET_nios is not set
-# TARGET_nios2 is not set
-# TARGET_powerpc is not set
-# TARGET_sh is not set
-# TARGET_sh64 is not set
-# TARGET_sparc is not set
-# TARGET_v850 is not set
-# TARGET_x86_64 is not set
-
-#
-# Target Architecture Features and Options
-#
-TARGET_ARCH="i386"
-# ARCH_SUPPORTS_BIG_ENDIAN is not set
-ARCH_SUPPORTS_LITTLE_ENDIAN=y
-FORCE_OPTIONS_FOR_ARCH=y
-# CONFIG_GENERIC_386 is not set
-# CONFIG_386 is not set
-# CONFIG_486 is not set
-# CONFIG_586 is not set
-# CONFIG_586MMX is not set
-# CONFIG_686 is not set
-# CONFIG_PENTIUMII is not set
-# CONFIG_PENTIUMIII is not set
-CONFIG_PENTIUM4=y
-# CONFIG_K6 is not set
-# CONFIG_K7 is not set
-# CONFIG_ELAN is not set
-# CONFIG_CRUSOE is not set
-# CONFIG_WINCHIPC6 is not set
-# CONFIG_WINCHIP2 is not set
-# CONFIG_CYRIXIII is not set
-# CONFIG_NEHEMIAH is not set
-ARCH_LITTLE_ENDIAN=y
-# ARCH_BIG_ENDIAN is not set
-# ARCH_HAS_NO_MMU is not set
-ARCH_HAS_MMU=y
-UCLIBC_HAS_FLOATS=y
-UCLIBC_HAS_FPU=y
-DO_C99_MATH=y
-# UCLIBC_HAS_FENV is not set
-KERNEL_HEADERS="<path/to/kernel/headers>"
-HAVE_DOT_CONFIG=y
diff --git a/meta/recipes-core/uclibc/uclibc-git/uClibc.config b/meta/recipes-core/uclibc/uclibc-git/uClibc.config
deleted file mode 100644 (file)
index e69de29..0000000
index a1b7813a0bc14ee11ce2da4f0cc1d1d0719fdec9..45b131d1f0ec0b93d85fb3fdecc75dcc70808893 100644 (file)
@@ -157,4 +157,16 @@ WARNINGS="-Wall"
 DO_C99_MATH=y
 UCLIBC_HAS_LONG_DOUBLE_MATH=y
 UCLIBC_HAS_FENV=y
-
+UCLIBC_LINUX_SPECIFIC=y
+UCLIBC_HAS_REALTIME=y
+UCLIBC_HAS_ADVANCED_REALTIME=y
+UCLIBC_HAS_NETWORK_SUPPORT=y
+UCLIBC_HAS_SOCKET=y
+UCLIBC_HAS_BSD_ERR=y
+UCLIBC_HAS_SYSLOG=y
+UCLIBC_HAS_CRYPT=y
+UCLIBC_HAS_CRYPT_IMPL=y
+UCLIBC_HAS_GNU_ERROR=y
+UCLIBC_HAS_PTY=y
+UCLIBC_BSD_SPECIFIC=y
+UCLIBC_HAS_EPOLL=y
index c1bc42264e883c43040a0a0d5a0960e3ab6f3065..15d4e52708cebe70de6d84375a2df4dc770c4b7d 100644 (file)
@@ -202,12 +202,11 @@ do_configure() {
         echo "### FPU" >>${S}/merged.config
         echo "### ABI" >>${S}/merged.config
         echo "### DISTRO FEATURES" >>${S}/merged.config
-        cp ${S}/merged.config ${S}/.config
 
         # Mangle the resulting .config depending on OE variables
-        sed -i -e '${configmangle}' ${S}/.config
+        sed -i -e '${configmangle}' ${S}/merged.config
 
-        oe_runmake oldconfig
+        oe_runmake KCONFIG_ALLCONFIG=${S}/merged.config allnoconfig
 }
 
 do_install() {
index eded2fbd8f3a0432e9ffe22bfd83333b6fef2e4d..6c88513bc6f1327d482c1049c491e3ff48195a86 100644 (file)
@@ -10,7 +10,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/uclibc-git' ], d)}"
 
 SRC_URI = "git://uclibc.org/uClibc.git;branch=master;protocol=git \
-       file://uClibc.config \
        file://uClibc.machine \
        file://uClibc.distro \
        file://uclibc-arm-ftruncate64.patch \