]> code.ossystems Code Review - openembedded-core.git/commitdiff
bitbake.conf/python: Drop setting RDEPENDS/RPROVIDES default
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jan 2021 14:46:43 +0000 (14:46 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Jan 2021 21:21:27 +0000 (21:21 +0000)
We never recommend setting RDEPENDS or RPROVIDES without a package name
against them. The default in bitbake.conf is legacy only, drop it.

The python recipe was trying to add to the empty variable in the native case
fix that too.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/bitbake.conf
meta/recipes-devtools/python/python3_3.9.1.bb

index 74976ac05c2db1abda4c4ab79e04051bd133546f..3438be92b7fb2b77ed4d0aca652344b655edd613 100644 (file)
@@ -272,10 +272,8 @@ DEPCHAIN_PRE = ""
 DEPCHAIN_POST = "-dev -dbg"
 
 DEPENDS = ""
-RDEPENDS = ""
 PROVIDES = ""
 PROVIDES_prepend = "${PN} "
-RPROVIDES = ""
 
 MULTI_PROVIDER_WHITELIST = "virtual/libintl virtual/libintl-native virtual/nativesdk-libintl virtual/xserver virtual/update-alternatives-native virtual/update-alternatives"
 
index a89122f94943eaf690df549ceeffbb822a57f2ae..a2dc572672cad26e68d7e1af27850310443d10b3 100644 (file)
@@ -240,7 +240,7 @@ python(){
     # First set RPROVIDES for -native case
     # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
     pn = 'python3'
-    rprovides = d.getVar('RPROVIDES').split()
+    rprovides = (d.getVar('RPROVIDES') or "").split()
 
     # ${PN}-misc-native is not in the manifest
     rprovides.append(pn + '-misc-native')