]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc: Fix removal of libiberty.a
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 4 Jul 2011 14:37:18 +0000 (15:37 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 5 Jul 2011 10:16:35 +0000 (11:16 +0100)
The changes in commit 553a92c442bc3a35d1520a22e640a3a0e377b8f7 were not applying correctly
due to the error: "find: paths must precede expression"

This patch corrects the find syntax.

[YOCTO #1199]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gcc/gcc-4.6.inc
meta/recipes-devtools/gcc/gcc-cross-intermediate.inc
meta/recipes-devtools/gcc/gcc-package-cross.inc
meta/recipes-devtools/gcc/gcc-package-target.inc
meta/recipes-devtools/gcc/gcc_4.5.1.bb

index a0120492aeb8d486e52c7f554c4c4da6d2167c3b..68449954afe856f04e417cb7d65eebbe0b0f583c 100644 (file)
@@ -1,6 +1,6 @@
 require gcc-common.inc
 
-PR = "r4"
+PR = "r5"
 
 # Third digit in PV should be incremented after a minor release
 # happens from this branch on gcc e.g. currently its 4.6.0
index 05b5dbc089a4fb7b8534de07c1488495ba0154fa..df5958ac773b4c41634abc167d074a7ba6182c86 100644 (file)
@@ -40,8 +40,8 @@ do_install () {
        rm -rf ${D}${datadir}/
 
        # We use libiberty from binutils
-       find -name libiberty.a ${D}${exec_prefix}/lib | xargs rm -f
-       find -name libiberty.h ${D}${exec_prefix}/lib | xargs rm -f
+       find ${D}${exec_prefix}/lib -name libiberty.a | xargs rm -f
+       find ${D}${exec_prefix}/lib -name libiberty.h | xargs rm -f
 
        # Insert symlinks into libexec so when tools without a prefix are searched for, the correct ones are
        # found. These need to be relative paths so they work in different locations.
index b51336bf2d919bdd927256b17d7122877496d728..3d27788c56248f0ba437aa99844c386410354aaf 100644 (file)
@@ -29,8 +29,8 @@ do_install () {
        done
 
        # We use libiberty from binutils
-       find -name libiberty.a ${D}${exec_prefix}/lib | xargs rm -f
-       find -name libiberty.h ${D}${exec_prefix}/lib | xargs rm -f
+       find ${D}${exec_prefix}/lib -name libiberty.a | xargs rm -f
+       find ${D}${exec_prefix}/lib -name libiberty.h | xargs rm -f
 
        # gcc-runtime installs libgcc into a special location in staging since it breaks doing a standalone build
        if [ "${PN}" == "gcc-cross" -o "${PN}" == "gcc-crosssdk" ]; then
index 43e2bd5dbaca8fd110f4dd347e0ffcf193b24fc6..6cc308c6dc3726e86e361d21fbcd760c4aa35f82 100644 (file)
@@ -88,8 +88,8 @@ do_install () {
        rm -f *gcc-?.?*
 
        # We use libiberty from binutils
-       find -name libiberty.a ${D}${exec_prefix}/lib | xargs rm -f
-       find -name libiberty.h ${D}${exec_prefix}/lib | xargs rm -f
+       find ${D}${exec_prefix}/lib -name libiberty.a | xargs rm -f
+       find ${D}${exec_prefix}/lib -name libiberty.h | xargs rm -f
 
        # Symlinks so we can use these trivially on the target
        ln -sf ${TARGET_PREFIX}g77 g77 || true
index e04f443b4d6c0055f9df1832f61951d2d61072ce..785d719ac88d6fcdf9b58b1a0ee10f40a2fd0641 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
 require gcc-${PV}.inc
 require gcc-configure-target.inc
 require gcc-package-target.inc