]> code.ossystems Code Review - openembedded-core.git/commitdiff
dpkg: fix package_deb error for linux-wrs
authorDongxiao Xu <dongxiao.xu@intel.com>
Sat, 9 Oct 2010 05:40:51 +0000 (13:40 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Sat, 9 Oct 2010 17:15:50 +0000 (10:15 -0700)
The new dpkg will report linux-wrs version parse error,
since there is a '_' inside. This patch fixes this issue.

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/recipes-devtools/dpkg/dpkg/check_version.patch [new file with mode: 0644]
meta/recipes-devtools/dpkg/dpkg_1.15.8.5.bb

diff --git a/meta/recipes-devtools/dpkg/dpkg/check_version.patch b/meta/recipes-devtools/dpkg/dpkg/check_version.patch
new file mode 100644 (file)
index 0000000..a09e136
--- /dev/null
@@ -0,0 +1,21 @@
+Adapt to linux-wrs kernel version, which has character '_' inside.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN dpkg-1.15.8.5-orig/lib/dpkg/parsehelp.c dpkg-1.15.8.5/lib/dpkg/parsehelp.c
+--- dpkg-1.15.8.5-orig/lib/dpkg/parsehelp.c    2010-10-08 12:27:15.058572774 +0800
++++ dpkg-1.15.8.5/lib/dpkg/parsehelp.c 2010-10-09 11:18:15.484190771 +0800
+@@ -268,11 +268,11 @@
+   /* XXX: Would be faster to use something like cisversion and cisrevision. */
+   for (ptr = rversion->version; *ptr; ptr++) {
+-    if (!cisdigit(*ptr) && !cisalpha(*ptr) && strchr(".-+~:", *ptr) == NULL)
++    if (!cisdigit(*ptr) && !cisalpha(*ptr) && strchr(".-+~:_", *ptr) == NULL)
+       return _("invalid character in version number");
+   }
+   for (ptr = rversion->revision; *ptr; ptr++) {
+-    if (!cisdigit(*ptr) && !cisalpha(*ptr) && strchr(".-+~", *ptr) == NULL)
++    if (!cisdigit(*ptr) && !cisalpha(*ptr) && strchr(".-+~_", *ptr) == NULL)
+       return _("invalid character in revision number");
+   }
index 2562f4b7245777a6f1aa3228fbaab3c573738ad8..760ecd323944d7af715532f61c6dc07291540770 100644 (file)
@@ -1,7 +1,8 @@
 require dpkg.inc
 
 SRC_URI += "file://noman.patch;patch=1 \
-            file://check_snprintf.patch"
+            file://check_snprintf.patch \
+            file://check_version.patch"
 
 EXTRA_OECONF = "--without-static-progs \
                --without-dselect \