]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp: use PACKAGECONFIG to address readline dependency
authorMing Liu <ming.liu@windriver.com>
Thu, 17 Jul 2014 07:58:18 +0000 (15:58 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 17 Jul 2014 11:36:10 +0000 (12:36 +0100)
To avoid automatically detecting readline dependency, which will lead to
a implicit build result.

Signed-off-by: Ming Liu <ming.liu@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/gmp/gmp.inc
meta/recipes-support/gmp/gmp_4.2.1.bb

index d025e07256cced8ebcd84d1ce77e264f501fc398..6aedc85f584ff41334bcf64486201eb65caa0960 100644 (file)
@@ -18,6 +18,9 @@ acpaths = ""
 
 BBCLASSEXTEND = "native nativesdk"
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[readline] = "--with-readline=yes,--with-readline=no,readline"
+
 EXTRA_OECONF += " --enable-cxx=detect"
 
 PACKAGES =+ "libgmpxx"
index 5c93925daa4372bad6f0a0259a3facfb2b62cac1..69ad0ca670a662fe608bbb2704c0f9308498bc68 100644 (file)
@@ -17,4 +17,7 @@ SRC_URI = "${GNU_MIRROR}/gmp/${BP}.tar.bz2 \
 SRC_URI[md5sum] = "091c56e0e1cca6b09b17b69d47ef18e3"
 SRC_URI[sha256sum] = "d07ffcb37eecec35c5ec72516d10b35fdf6e6fef1fcf1dcd37e30b8cbf8bf941"
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[readline] = "--with-readline=yes,--with-readline=no,readline"
+
 inherit autotools texinfo