]> code.ossystems Code Review - openembedded-core.git/commitdiff
cmake: remove unused dont-run-cross-binaries.patch
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 6 Apr 2016 06:58:42 +0000 (23:58 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 6 Apr 2016 09:31:41 +0000 (10:31 +0100)
It hasn't been used since June 2015 when upgraded the recipe, this patch
was used for crosscompiling, now the crosscompile works well without it,
so remove it.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch [deleted file]

diff --git a/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch b/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
deleted file mode 100644 (file)
index 0c059f1..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-cmake: don't run cross-binaries on host machine
-
-When doing the cross build we obviously cannot run those binaries on
-host since they can be binary incompatible.
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-
-Index: cmake-2.8.10.1/CMakeLists.txt
-===================================================================
---- cmake-2.8.10.1.orig/CMakeLists.txt
-+++ cmake-2.8.10.1/CMakeLists.txt
-@@ -588,7 +588,8 @@ mark_as_advanced(CMAKE_STRICT)
- # build the remaining subdirectories
- add_subdirectory(Source)
--add_subdirectory(Utilities)
-+# Come on! Running the cross-binaries on host is not a good idea.
-+#add_subdirectory(Utilities)
- add_subdirectory(Tests)
- if(BUILD_TESTING)