]> code.ossystems Code Review - openembedded-core.git/commitdiff
ethtool: Fix ptest compile
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 22 Nov 2013 09:24:04 +0000 (09:24 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 12 Dec 2013 16:53:10 +0000 (16:53 +0000)
buildtest-TESTS is a phony target and does nothing which results in a
do_install error since the tests aren't built. Since there isn't
a suitable make target but the number of tests are small, hardcode
the two to build to unbreak the build when ptest is enabled.

(From OE-Core master rev: 5dd8653fdcda5e0e8b4f3c37a46f357bc97ec66c)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-extended/ethtool/ethtool_3.10.bb

index 83587d90be31a25df68f270dbab44f2e903eaba5..d23c285cffe5b1b35493917e186357a3fe3c9504 100644 (file)
@@ -16,7 +16,7 @@ inherit autotools ptest
 RDEPENDS_${PN}-ptest += "make"
 
 do_compile_ptest() {
-   oe_runmake buildtest-TESTS
+   oe_runmake test-cmdline test-features
 }
 
 do_install_ptest () {