]> code.ossystems Code Review - openembedded-core.git/commitdiff
Until the interactive mode is fixed, kill it from the valid options, to avoid confusion
authorChris Larson <chris_larson@mentor.com>
Fri, 18 Jun 2010 15:07:51 +0000 (08:07 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 2 Jul 2010 14:41:37 +0000 (15:41 +0100)
(Bitbake rev: 65a51bb20677148a29b9e472f6d9d0a97798f024)

Signed-off-by: Chris Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake
bitbake/lib/bb/cooker.py

index 54228518d714feb7765a94b2880617ed065f82b8..34cfadb986cebc18dda21380cb2dfcb7da9982b1 100755 (executable)
@@ -105,9 +105,6 @@ Default BBFILES are the .bb files in the current directory.""")
     parser.add_option("-f", "--force", help = "force run of specified cmd, regardless of stamp status",
                action = "store_true", dest = "force", default = False)
 
-    parser.add_option("-i", "--interactive", help = "drop into the interactive mode also called the BitBake shell.",
-               action = "store_true", dest = "interactive", default = False)
-
     parser.add_option("-c", "--cmd", help = "Specify task to execute. Note that this only executes the specified task for the providee and the packages it depends on, i.e. 'compile' does not implicitly call stage for the dependencies (IOW: use only if you know what you are doing). Depending on the base.bbclass a listtasks tasks is defined and will show available tasks",
                action = "store", dest = "cmd")
 
index fd59f052321138cdd57d62cce6f0570fd3b25d2d..2b3dfb0cb4dc23ed54f0f5d66820a089a70e979f 100644 (file)
@@ -140,9 +140,6 @@ class BBCooker:
             self.commandlineAction = ["showVersions"]
         elif self.configuration.parse_only:
             self.commandlineAction = ["parseFiles"]
-        # FIXME - implement
-        #elif self.configuration.interactive:
-        #    self.interactiveMode()
         elif self.configuration.dot_graph:
             if self.configuration.pkgs_to_build:
                 self.commandlineAction = ["generateDotGraph", self.configuration.pkgs_to_build, self.configuration.cmd]