]> code.ossystems Code Review - openembedded-core.git/commitdiff
intltool: Fix perl paths
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Aug 2011 10:26:58 +0000 (11:26 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Aug 2011 17:06:37 +0000 (18:06 +0100)
Currently in the native case we have a path that can easily exceed the
interpretor limit so use "env nativeperl" in that case.

This patch also fixes up the target version's interpretor path but
to do this we need to bypass the configure checks.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/intltool/intltool-0.40.6/noperlcheck.patch [new file with mode: 0644]
meta/recipes-devtools/intltool/intltool.inc
meta/recipes-devtools/intltool/intltool_0.40.6.bb

diff --git a/meta/recipes-devtools/intltool/intltool-0.40.6/noperlcheck.patch b/meta/recipes-devtools/intltool/intltool-0.40.6/noperlcheck.patch
new file mode 100644 (file)
index 0000000..3d8b591
--- /dev/null
@@ -0,0 +1,40 @@
+In the target case, we can't check if perl exists or try running it. If we
+don't patch the code, the native perl location would be used, not the target
+which is also incorrect. We therefore disable this code and rely on the 
+correct value of PERL being passed in.
+
+RP 31/8/2011
+
+Upstream-Status: Inappropriate [OE specific]
+
+Index: intltool-0.40.6/configure.in
+===================================================================
+--- intltool-0.40.6.orig/configure.in  2011-08-31 11:21:13.061160535 +0100
++++ intltool-0.40.6/configure.in       2011-08-31 11:22:44.991160885 +0100
+@@ -9,24 +9,10 @@
+ aclocaldir='${datadir}'/aclocal
+ AC_SUBST(aclocaldir)
+-AC_PATH_PROG(PERL, perl)
+ if test -z "$PERL"; then
+-   AC_MSG_ERROR([perl not found])
+-fi
+-AC_MSG_CHECKING([for perl >= 5.8.1])
+-$PERL -e "use 5.8.1;" > /dev/null 2>&1
+-if test $? -ne 0; then
+-   AC_MSG_ERROR([perl 5.8.1 is required for intltool])
+-else
+-   PERL_VERSION="`$PERL -e \"printf '%vd', $^V\"`"
+-   AC_MSG_RESULT([$PERL_VERSION])
+-fi
+-AC_MSG_CHECKING([for XML::Parser])
+-if `$PERL -e "require XML::Parser" 2>/dev/null`; then
+-   AC_MSG_RESULT([ok])
+-else
+-   AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++   AC_MSG_ERROR([PERL variable not set])
+ fi
++AC_SUBST(PERL)
+ AC_OUTPUT([
+ Makefile
index 7e11fc9da9ede182a7e33b678bcc1e286e9298f8..8d4bec5227fd57e2d42d90ddfaeec6e40155967c 100644 (file)
@@ -13,4 +13,7 @@ RRECOMMENDS_${PN}_virtclass-native = ""
 
 inherit autotools pkgconfig perlnative
 
+export PERL = "${bindir}/env perl"
+PERL_virtclass-native = "/usr/bin/env nativeperl"
+
 BBCLASSEXTEND = "native"
index 931122dac265284fa9b23641f243ceca36e5eb34..e9871fc098f6c9a737f6c1468b73cda310b8f83b 100644 (file)
@@ -1,13 +1,13 @@
 require intltool.inc
 LICENSE="GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r4"
+PR = "r5"
 
 SRC_URI_append = " file://intltool-nowarn-0.40.0.patch \
                    ${NATIVEPATCHES} \
                  "
 
-NATIVEPATCHES = ""
+NATIVEPATCHES = "file://noperlcheck.patch"
 NATIVEPATCHES_virtclass-native = "file://use-nativeperl.patch"
 
 SRC_URI[md5sum] = "69bc0353323112f42ad4f9cf351bc3e5"