]> code.ossystems Code Review - openembedded-core.git/commitdiff
libgloss_3.0.0.bb: Consolidate rmdir with -p
authorNathan Rossi <nathan@nathanrossi.com>
Fri, 14 Sep 2018 11:10:07 +0000 (11:10 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 21 Sep 2018 15:15:19 +0000 (08:15 -0700)
Consolidate the rmdir of multiple directories with the use of -p to
delete the leaf empty directory and any empty ancestor directories.

Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/newlib/libgloss_3.0.0.bb

index 727062ca5d15847b3bc351ff397ce470381ba198..e412153dab03b6ab576ee0ffe888cd3b174ad071 100644 (file)
@@ -21,8 +21,7 @@ do_install_append() {
        mv -v ${D}${prefix}/${TARGET_SYS}/lib/* ${D}${libdir}
 
        # Remove original directory
-       rmdir ${D}${prefix}/${TARGET_SYS}/lib
-       rmdir ${D}${prefix}/${TARGET_SYS}
+       rmdir -p --ignore-fail-on-non-empty ${D}${prefix}/${TARGET_SYS}/lib
 }
 
 # Split packages correctly