]> code.ossystems Code Review - openembedded-core.git/commitdiff
mtools_4.0.18.bb: Use create_wrapper() for mcopy
authorRandy Witt <randy.e.witt@linux.intel.com>
Fri, 23 Oct 2015 02:46:11 +0000 (19:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 24 Oct 2015 11:21:03 +0000 (12:21 +0100)
mcopy uses the IBM850 codepage from gconv. The default install location
for gconv will not match the actual install location since it can be
pulled from sstate. This patch overrides the default location when
running by adding GCONV_PATH to the environment for mcopy.

[YOCTO #7629]

Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/mtools/mtools_4.0.18.bb

index 52decfdf63ec789ff9e45fbb4b86504d5e5970ae..24c9d49312ae2895057f15d5e850618f89080274 100644 (file)
@@ -45,3 +45,8 @@ do_install_prepend () {
     mkdir -p ${D}/${bindir}
     mkdir -p ${D}/${datadir}
 }
+
+do_install_append_class-native () {
+    create_wrapper ${D}${bindir}/mcopy \
+        GCONV_PATH=${libdir}/gconv
+}