]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: add do_install after NATIVE_INSTALL_WORKS
authorKevin Tian <kevin.tian@intel.com>
Thu, 22 Jul 2010 05:36:42 +0000 (13:36 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 22 Jul 2010 08:30:15 +0000 (09:30 +0100)
NATIVE_INSTALL_WORKS implicates an explicit do_install required or else
its binaries are not installed to sysroot, which result in error like:
   sh: opkg-build not found

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/packages/opkg-utils/opkg-utils_svn.bb

index 17dfbab7746d4417dc192480ac6fc1b5382f52e5..18259b3c39a7f6998d037e1a3cb50f151ae873c3 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
 RDEPENDS = "python"
 RDEPENDS_virtclass-native = ""
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
            file://index-ignore-filenotfound.patch"
@@ -17,6 +17,9 @@ S = "${WORKDIR}/opkg-utils"
 # Avoid circular dependencies from package_ipk.bbclass
 PACKAGES_virtclass-native = ""
 
-NATIVE_INSTALL_WORKS = "1"
+do_install() {
+       oe_runmake PREFIX=${prefix} DESTDIR=${D} install
+}
 
+NATIVE_INSTALL_WORKS = "1"
 BBCLASSEXTEND = "native"