]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc_2.13: Add support for handling sqrt & sqrtf on powerpc
authorKumar Gala <galak@kernel.crashing.org>
Mon, 1 Aug 2011 14:26:22 +0000 (09:26 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 Aug 2011 14:01:18 +0000 (15:01 +0100)
Some of powerpc's dont support the fsqrt[s] instructions so we need an
implementation of the library functions for those processors.

Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
meta/recipes-core/eglibc/eglibc-2.13/ppc-sqrt.patch [new file with mode: 0644]
meta/recipes-core/eglibc/eglibc_2.13.bb

diff --git a/meta/recipes-core/eglibc/eglibc-2.13/ppc-sqrt.patch b/meta/recipes-core/eglibc/eglibc-2.13/ppc-sqrt.patch
new file mode 100644 (file)
index 0000000..0c6f0cb
--- /dev/null
@@ -0,0 +1,538 @@
+Upstream-Status: Pending\r
+\r
+2011-03-22  Joseph Myers  <joseph@codesourcery.com>\r
+\r
+        Merge from SG++ 2.11:\r
+\r
+        2010-10-05  Nathan Froyd  <froydnj@codesourcery.com>\r
+\r
+        Issue #9382\r
+\r
+        * sysdeps/powerpc/powerpc32/603e/: New directory.\r
+        * sysdeps/unix/sysv/linux/powerpc/powerpc32/e500mc/: New directory.\r
+        * sysdeps/unix/sysv/linux/powerpc/powerpc32/603e/: New directory.\r
+        * sysdeps/unix/sysv/linux/powerpc/powerpc32/7400/: New directory.\r
+        * sysdeps/powerpc/powerpc64/e5500/fpu/e_sqrtf.c: Update.\r
+        * sysdeps/powerpc/powerpc64/e5500/fpu/e_sqrt.c: Update.\r
+        * sysdeps/powerpc/powerpc64/e5500/fpu/Implies: New file.\r
+\r
+Index: libc/sysdeps/powerpc/powerpc32/603e/fpu/e_sqrt.c\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/powerpc/powerpc32/603e/fpu/e_sqrt.c\r
+@@ -0,0 +1,134 @@\r
++/* Double-precision floating point square root.\r
++   Copyright (C) 2010 Free Software Foundation, Inc.\r
++   This file is part of the GNU C Library.\r
++\r
++   The GNU C Library is free software; you can redistribute it and/or\r
++   modify it under the terms of the GNU Lesser General Public\r
++   License as published by the Free Software Foundation; either\r
++   version 2.1 of the License, or (at your option) any later version.\r
++\r
++   The GNU C Library is distributed in the hope that it will be useful,\r
++   but WITHOUT ANY WARRANTY; without even the implied warranty of\r
++   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU\r
++   Lesser General Public License for more details.\r
++\r
++   You should have received a copy of the GNU Lesser General Public\r
++   License along with the GNU C Library; if not, write to the Free\r
++   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA\r
++   02111-1307 USA.  */\r
++\r
++#include <math.h>\r
++#include <math_private.h>\r
++#include <fenv_libc.h>\r
++#include <inttypes.h>\r
++\r
++#include <sysdep.h>\r
++#include <ldsodefs.h>\r
++\r
++static const ieee_float_shape_type a_nan = {.word = 0x7fc00000 };\r
++static const ieee_float_shape_type a_inf = {.word = 0x7f800000 };\r
++static const float two108 = 3.245185536584267269e+32;\r
++static const float twom54 = 5.551115123125782702e-17;\r
++static const float half = 0.5;\r
++\r
++/* The method is based on the descriptions in:\r
++\r
++   _The Handbook of Floating-Pointer Arithmetic_ by Muller et al., chapter 5;\r
++   _IA-64 and Elementary Functions: Speed and Precision_ by Markstein, chapter 9\r
++\r
++   We find the actual square root and half of its reciprocal\r
++   simultaneously.  */\r
++\r
++#ifdef __STDC__\r
++double\r
++__ieee754_sqrt (double b)\r
++#else\r
++double\r
++__ieee754_sqrt (b)\r
++     double b;\r
++#endif\r
++{\r
++  if (__builtin_expect (b > 0, 1))\r
++    {\r
++      double y, g, h, d, r;\r
++      ieee_double_shape_type u;\r
++\r
++      if (__builtin_expect (b != a_inf.value, 1))\r
++        {\r
++          fenv_t fe;\r
++\r
++          fe = fegetenv_register ();\r
++\r
++          u.value = b;\r
++\r
++          relax_fenv_state ();\r
++\r
++          __asm__ ("frsqrte %[estimate], %[x]\n"\r
++                   : [estimate] "=f" (y) : [x] "f" (b));\r
++\r
++          /* Following Muller et al, page 168, equation 5.20.\r
++\r
++             h goes to 1/(2*sqrt(b))\r
++             g goes to sqrt(b).\r
++\r
++             We need three iterations to get within 1ulp.  */\r
++\r
++          /* Indicate that these can be performed prior to the branch.  GCC\r
++             insists on sinking them below the branch, however; it seems like\r
++             they'd be better before the branch so that we can cover any latency\r
++             from storing the argument and loading its high word.  Oh well.  */\r
++\r
++          g = b * y;\r
++          h = 0.5 * y;\r
++  \r
++          /* Handle small numbers by scaling.  */\r
++          if (__builtin_expect ((u.parts.msw & 0x7ff00000) <= 0x02000000, 0))\r
++            return __ieee754_sqrt (b * two108) * twom54;\r
++\r
++#define FMADD(a_, c_, b_)                                               \\r
++          ({ double __r;                                                \\r
++          __asm__ ("fmadd %[r], %[a], %[c], %[b]\n"                     \\r
++                   : [r] "=f" (__r) : [a] "f" (a_), [c] "f" (c_), [b] "f" (b_)); \\r
++          __r;})\r
++#define FNMSUB(a_, c_, b_)                                          \\r
++          ({ double __r;                                                \\r
++          __asm__ ("fnmsub %[r], %[a], %[c], %[b]\n"                     \\r
++                   : [r] "=f" (__r) : [a] "f" (a_), [c] "f" (c_), [b] "f" (b_)); \\r
++          __r;})\r
++\r
++          r = FNMSUB (g, h, half);\r
++          g = FMADD (g, r, g);\r
++          h = FMADD (h, r, h);\r
++\r
++          r = FNMSUB (g, h, half);\r
++          g = FMADD (g, r, g);\r
++          h = FMADD (h, r, h);\r
++\r
++          r = FNMSUB (g, h, half);\r
++          g = FMADD (g, r, g);\r
++          h = FMADD (h, r, h);\r
++\r
++          /* g is now +/- 1ulp, or exactly equal to, the square root of b.  */\r
++\r
++          /* Final refinement.  */\r
++          d = FNMSUB (g, g, b);\r
++\r
++          fesetenv_register (fe);\r
++          return FMADD (d, h, g);\r
++        }\r
++    }\r
++  else if (b < 0)\r
++    {\r
++      /* For some reason, some PowerPC32 processors don't implement\r
++         FE_INVALID_SQRT.  */\r
++#ifdef FE_INVALID_SQRT\r
++      feraiseexcept (FE_INVALID_SQRT);\r
++\r
++      fenv_union_t u = { .fenv = fegetenv_register () };\r
++      if ((u.l[1] & FE_INVALID) == 0)\r
++#endif\r
++      feraiseexcept (FE_INVALID);\r
++      b = a_nan.value;\r
++    }\r
++  return f_wash (b);\r
++}\r
+Index: libc/sysdeps/powerpc/powerpc32/603e/fpu/e_sqrtf.c\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/powerpc/powerpc32/603e/fpu/e_sqrtf.c\r
+@@ -0,0 +1,101 @@\r
++/* Single-precision floating point square root.\r
++   Copyright (C) 2010 Free Software Foundation, Inc.\r
++   This file is part of the GNU C Library.\r
++\r
++   The GNU C Library is free software; you can redistribute it and/or\r
++   modify it under the terms of the GNU Lesser General Public\r
++   License as published by the Free Software Foundation; either\r
++   version 2.1 of the License, or (at your option) any later version.\r
++\r
++   The GNU C Library is distributed in the hope that it will be useful,\r
++   but WITHOUT ANY WARRANTY; without even the implied warranty of\r
++   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU\r
++   Lesser General Public License for more details.\r
++\r
++   You should have received a copy of the GNU Lesser General Public\r
++   License along with the GNU C Library; if not, write to the Free\r
++   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA\r
++   02111-1307 USA.  */\r
++\r
++#include <math.h>\r
++#include <math_private.h>\r
++#include <fenv_libc.h>\r
++#include <inttypes.h>\r
++\r
++#include <sysdep.h>\r
++#include <ldsodefs.h>\r
++\r
++static const ieee_float_shape_type a_nan = {.word = 0x7fc00000 };\r
++static const ieee_float_shape_type a_inf = {.word = 0x7f800000 };\r
++static const float threehalf = 1.5;\r
++\r
++/* The method is based on the descriptions in:\r
++\r
++   _The Handbook of Floating-Pointer Arithmetic_ by Muller et al., chapter 5;\r
++   _IA-64 and Elementary Functions: Speed and Precision_ by Markstein, chapter 9\r
++\r
++   We find the reciprocal square root and use that to compute the actual\r
++   square root.  */\r
++\r
++#ifdef __STDC__\r
++float\r
++__ieee754_sqrtf (float b)\r
++#else\r
++float\r
++__ieee754_sqrtf (b)\r
++     float b;\r
++#endif\r
++{\r
++  if (__builtin_expect (b > 0, 1))\r
++    {\r
++#define FMSUB(a_, c_, b_)                                               \\r
++      ({ double __r;                                                    \\r
++        __asm__ ("fmsub %[r], %[a], %[c], %[b]\n"                       \\r
++                 : [r] "=f" (__r) : [a] "f" (a_), [c] "f" (c_), [b] "f" (b_)); \\r
++        __r;})\r
++#define FNMSUB(a_, c_, b_)                                              \\r
++      ({ double __r;                                                    \\r
++        __asm__ ("fnmsub %[r], %[a], %[c], %[b]\n"                      \\r
++                 : [r] "=f" (__r) : [a] "f" (a_), [c] "f" (c_), [b] "f" (b_)); \\r
++        __r;})\r
++\r
++      if (__builtin_expect (b != a_inf.value, 1))\r
++        {\r
++          double y, x;\r
++          fenv_t fe;\r
++\r
++          fe = fegetenv_register ();\r
++\r
++          relax_fenv_state ();\r
++\r
++          /* Compute y = 1.5 * b - b.  Uses fewer constants than y = 0.5 * b.  */\r
++          y = FMSUB (threehalf, b, b);\r
++\r
++          /* Initial estimate.  */\r
++          __asm__ ("frsqrte %[x], %[b]\n" : [x] "=f" (x) : [b] "f" (b));\r
++\r
++          /* Iterate.  x_{n+1} = x_n * (1.5 - y * (x_n * x_n)).  */\r
++          x = x * FNMSUB (y, x * x, threehalf);\r
++          x = x * FNMSUB (y, x * x, threehalf);\r
++          x = x * FNMSUB (y, x * x, threehalf);\r
++\r
++          /* All done.  */\r
++          fesetenv_register (fe);\r
++          return x * b;\r
++        }\r
++    }\r
++  else if (b < 0)\r
++    {\r
++      /* For some reason, some PowerPC32 processors don't implement\r
++         FE_INVALID_SQRT.  */\r
++#ifdef FE_INVALID_SQRT\r
++      feraiseexcept (FE_INVALID_SQRT);\r
++\r
++      fenv_union_t u = { .fenv = fegetenv_register () };\r
++      if ((u.l[1] & FE_INVALID) == 0)\r
++#endif\r
++      feraiseexcept (FE_INVALID);\r
++      b = a_nan.value;\r
++    }\r
++  return f_washf (b);\r
++}\r
+Index: libc/sysdeps/powerpc/powerpc64/e5500/fpu/e_sqrt.c\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/powerpc/powerpc64/e5500/fpu/e_sqrt.c\r
+@@ -0,0 +1,134 @@\r
++/* Double-precision floating point square root.\r
++   Copyright (C) 2010 Free Software Foundation, Inc.\r
++   This file is part of the GNU C Library.\r
++\r
++   The GNU C Library is free software; you can redistribute it and/or\r
++   modify it under the terms of the GNU Lesser General Public\r
++   License as published by the Free Software Foundation; either\r
++   version 2.1 of the License, or (at your option) any later version.\r
++\r
++   The GNU C Library is distributed in the hope that it will be useful,\r
++   but WITHOUT ANY WARRANTY; without even the implied warranty of\r
++   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU\r
++   Lesser General Public License for more details.\r
++\r
++   You should have received a copy of the GNU Lesser General Public\r
++   License along with the GNU C Library; if not, write to the Free\r
++   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA\r
++   02111-1307 USA.  */\r
++\r
++#include <math.h>\r
++#include <math_private.h>\r
++#include <fenv_libc.h>\r
++#include <inttypes.h>\r
++\r
++#include <sysdep.h>\r
++#include <ldsodefs.h>\r
++\r
++static const ieee_float_shape_type a_nan = {.word = 0x7fc00000 };\r
++static const ieee_float_shape_type a_inf = {.word = 0x7f800000 };\r
++static const float two108 = 3.245185536584267269e+32;\r
++static const float twom54 = 5.551115123125782702e-17;\r
++static const float half = 0.5;\r
++\r
++/* The method is based on the descriptions in:\r
++\r
++   _The Handbook of Floating-Pointer Arithmetic_ by Muller et al., chapter 5;\r
++   _IA-64 and Elementary Functions: Speed and Precision_ by Markstein, chapter 9\r
++\r
++   We find the actual square root and half of its reciprocal\r
++   simultaneously.  */\r
++\r
++#ifdef __STDC__\r
++double\r
++__ieee754_sqrt (double b)\r
++#else\r
++double\r
++__ieee754_sqrt (b)\r
++     double b;\r
++#endif\r
++{\r
++  if (__builtin_expect (b > 0, 1))\r
++    {\r
++      double y, g, h, d, r;\r
++      ieee_double_shape_type u;\r
++\r
++      if (__builtin_expect (b != a_inf.value, 1))\r
++        {\r
++          fenv_t fe;\r
++\r
++          fe = fegetenv_register ();\r
++\r
++          u.value = b;\r
++\r
++          relax_fenv_state ();\r
++\r
++          __asm__ ("frsqrte %[estimate], %[x]\n"\r
++                   : [estimate] "=f" (y) : [x] "f" (b));\r
++\r
++          /* Following Muller et al, page 168, equation 5.20.\r
++\r
++             h goes to 1/(2*sqrt(b))\r
++             g goes to sqrt(b).\r
++\r
++             We need three iterations to get within 1ulp.  */\r
++\r
++          /* Indicate that these can be performed prior to the branch.  GCC\r
++             insists on sinking them below the branch, however; it seems like\r
++             they'd be better before the branch so that we can cover any latency\r
++             from storing the argument and loading its high word.  Oh well.  */\r
++\r
++          g = b * y;\r
++          h = 0.5 * y;\r
++  \r
++          /* Handle small numbers by scaling.  */\r
++          if (__builtin_expect ((u.parts.msw & 0x7ff00000) <= 0x02000000, 0))\r
++            return __ieee754_sqrt (b * two108) * twom54;\r
++\r
++#define FMADD(a_, c_, b_)                                               \\r
++          ({ double __r;                                                \\r
++          __asm__ ("fmadd %[r], %[a], %[c], %[b]\n"                     \\r
++                   : [r] "=f" (__r) : [a] "f" (a_), [c] "f" (c_), [b] "f" (b_)); \\r
++          __r;})\r
++#define FNMSUB(a_, c_, b_)                                          \\r
++          ({ double __r;                                                \\r
++          __asm__ ("fnmsub %[r], %[a], %[c], %[b]\n"                     \\r
++                   : [r] "=f" (__r) : [a] "f" (a_), [c] "f" (c_), [b] "f" (b_)); \\r
++          __r;})\r
++\r
++          r = FNMSUB (g, h, half);\r
++          g = FMADD (g, r, g);\r
++          h = FMADD (h, r, h);\r
++\r
++          r = FNMSUB (g, h, half);\r
++          g = FMADD (g, r, g);\r
++          h = FMADD (h, r, h);\r
++\r
++          r = FNMSUB (g, h, half);\r
++          g = FMADD (g, r, g);\r
++          h = FMADD (h, r, h);\r
++\r
++          /* g is now +/- 1ulp, or exactly equal to, the square root of b.  */\r
++\r
++          /* Final refinement.  */\r
++          d = FNMSUB (g, g, b);\r
++\r
++          fesetenv_register (fe);\r
++          return FMADD (d, h, g);\r
++        }\r
++    }\r
++  else if (b < 0)\r
++    {\r
++      /* For some reason, some PowerPC32 processors don't implement\r
++         FE_INVALID_SQRT.  */\r
++#ifdef FE_INVALID_SQRT\r
++      feraiseexcept (FE_INVALID_SQRT);\r
++\r
++      fenv_union_t u = { .fenv = fegetenv_register () };\r
++      if ((u.l[1] & FE_INVALID) == 0)\r
++#endif\r
++      feraiseexcept (FE_INVALID);\r
++      b = a_nan.value;\r
++    }\r
++  return f_wash (b);\r
++}\r
+Index: libc/sysdeps/powerpc/powerpc64/e5500/fpu/e_sqrtf.c\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/powerpc/powerpc64/e5500/fpu/e_sqrtf.c\r
+@@ -0,0 +1,101 @@\r
++/* Single-precision floating point square root.\r
++   Copyright (C) 2010 Free Software Foundation, Inc.\r
++   This file is part of the GNU C Library.\r
++\r
++   The GNU C Library is free software; you can redistribute it and/or\r
++   modify it under the terms of the GNU Lesser General Public\r
++   License as published by the Free Software Foundation; either\r
++   version 2.1 of the License, or (at your option) any later version.\r
++\r
++   The GNU C Library is distributed in the hope that it will be useful,\r
++   but WITHOUT ANY WARRANTY; without even the implied warranty of\r
++   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU\r
++   Lesser General Public License for more details.\r
++\r
++   You should have received a copy of the GNU Lesser General Public\r
++   License along with the GNU C Library; if not, write to the Free\r
++   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA\r
++   02111-1307 USA.  */\r
++\r
++#include <math.h>\r
++#include <math_private.h>\r
++#include <fenv_libc.h>\r
++#include <inttypes.h>\r
++\r
++#include <sysdep.h>\r
++#include <ldsodefs.h>\r
++\r
++static const ieee_float_shape_type a_nan = {.word = 0x7fc00000 };\r
++static const ieee_float_shape_type a_inf = {.word = 0x7f800000 };\r
++static const float threehalf = 1.5;\r
++\r
++/* The method is based on the descriptions in:\r
++\r
++   _The Handbook of Floating-Pointer Arithmetic_ by Muller et al., chapter 5;\r
++   _IA-64 and Elementary Functions: Speed and Precision_ by Markstein, chapter 9\r
++\r
++   We find the reciprocal square root and use that to compute the actual\r
++   square root.  */\r
++\r
++#ifdef __STDC__\r
++float\r
++__ieee754_sqrtf (float b)\r
++#else\r
++float\r
++__ieee754_sqrtf (b)\r
++     float b;\r
++#endif\r
++{\r
++  if (__builtin_expect (b > 0, 1))\r
++    {\r
++#define FMSUB(a_, c_, b_)                                               \\r
++      ({ double __r;                                                    \\r
++        __asm__ ("fmsub %[r], %[a], %[c], %[b]\n"                       \\r
++                 : [r] "=f" (__r) : [a] "f" (a_), [c] "f" (c_), [b] "f" (b_)); \\r
++        __r;})\r
++#define FNMSUB(a_, c_, b_)                                              \\r
++      ({ double __r;                                                    \\r
++        __asm__ ("fnmsub %[r], %[a], %[c], %[b]\n"                      \\r
++                 : [r] "=f" (__r) : [a] "f" (a_), [c] "f" (c_), [b] "f" (b_)); \\r
++        __r;})\r
++\r
++      if (__builtin_expect (b != a_inf.value, 1))\r
++        {\r
++          double y, x;\r
++          fenv_t fe;\r
++\r
++          fe = fegetenv_register ();\r
++\r
++          relax_fenv_state ();\r
++\r
++          /* Compute y = 1.5 * b - b.  Uses fewer constants than y = 0.5 * b.  */\r
++          y = FMSUB (threehalf, b, b);\r
++\r
++          /* Initial estimate.  */\r
++          __asm__ ("frsqrte %[x], %[b]\n" : [x] "=f" (x) : [b] "f" (b));\r
++\r
++          /* Iterate.  x_{n+1} = x_n * (1.5 - y * (x_n * x_n)).  */\r
++          x = x * FNMSUB (y, x * x, threehalf);\r
++          x = x * FNMSUB (y, x * x, threehalf);\r
++          x = x * FNMSUB (y, x * x, threehalf);\r
++\r
++          /* All done.  */\r
++          fesetenv_register (fe);\r
++          return x * b;\r
++        }\r
++    }\r
++  else if (b < 0)\r
++    {\r
++      /* For some reason, some PowerPC32 processors don't implement\r
++         FE_INVALID_SQRT.  */\r
++#ifdef FE_INVALID_SQRT\r
++      feraiseexcept (FE_INVALID_SQRT);\r
++\r
++      fenv_union_t u = { .fenv = fegetenv_register () };\r
++      if ((u.l[1] & FE_INVALID) == 0)\r
++#endif\r
++      feraiseexcept (FE_INVALID);\r
++      b = a_nan.value;\r
++    }\r
++  return f_washf (b);\r
++}\r
+Index: libc/sysdeps/unix/sysv/linux/powerpc/powerpc32/603e/fpu/Implies\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/unix/sysv/linux/powerpc/powerpc32/603e/fpu/Implies\r
+@@ -0,0 +1 @@\r
++powerpc/powerpc32/603e/fpu\r
+Index: libc/sysdeps/unix/sysv/linux/powerpc/powerpc32/7400/fpu/Implies\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/unix/sysv/linux/powerpc/powerpc32/7400/fpu/Implies\r
+@@ -0,0 +1 @@\r
++powerpc/powerpc32/603e/fpu\r
+Index: libc/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500mc/fpu/Implies\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500mc/fpu/Implies\r
+@@ -0,0 +1 @@\r
++powerpc/powerpc32/603e/fpu\r
+Index: libc/sysdeps/unix/sysv/linux/powerpc/powerpc64/e5500/fpu/Implies\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/unix/sysv/linux/powerpc/powerpc64/e5500/fpu/Implies\r
+@@ -0,0 +1 @@\r
++powerpc/powerpc64/e5500/fpu\r
+Index: libc/sysdeps/unix/sysv/linux/powerpc/powerpc32/e5500/fpu/Implies\r
+===================================================================\r
+--- /dev/null\r
++++ libc/sysdeps/unix/sysv/linux/powerpc/powerpc32/e5500/fpu/Implies\r
+@@ -0,0 +1 @@\r
++powerpc/powerpc32/603e/fpu\r
index ddca50fe8b88ca264514dbc427f882323d0ccc38..b0a8bfdfe8b051f411dc27c2ffb98cb027a4c4ec 100644 (file)
@@ -3,7 +3,7 @@ require eglibc.inc
 SRCREV = "14157"
 
 DEPENDS += "gperf-native"
-PR = "r10"
+PR = "r11"
 PR_append = "+svnr${SRCPV}"
 
 EGLIBC_BRANCH="eglibc-2_13"
@@ -17,6 +17,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http
            file://etc/ld.so.conf \
            file://generate-supported.mk \
            file://glibc_bug_fix_12454.patch \
+           file://ppc-sqrt.patch \
           "
 LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
       file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \