]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Fix race issue for cpan/Pod-Simple
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 28 Dec 2018 09:01:49 +0000 (01:01 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Jan 2019 12:35:05 +0000 (12:35 +0000)
Fixed:
Running pm_to_blib for cpan/Pod-Simple directly
[snip]
/path/to/cpan/podlators/../../miniperl "-I../../lib" "-I../../lib" -MExtUtils::MY -e 'MY->fixin(shift)' -- blib/script/pod2man
Can't locate Getopt/Long.pm in @INC [snip]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl-native_5.24.4.bb
meta/recipes-devtools/perl/perl/0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch [new file with mode: 0644]
meta/recipes-devtools/perl/perl_5.24.4.bb

index 81d3fd48980325eecb14666d928b1637bea5805c..fe44d9b8e851741a07953ba9e4556133e74dfec4 100644 (file)
@@ -17,6 +17,7 @@ SRC_URI += "\
            file://0001-Configure-Remove-fstack-protector-strong-for-native-.patch \
            file://perl-5.26.1-guard_old_libcrypt_fix.patch \
            file://0001-ExtUtils-MM_Unix.pm-fix-race-issues.patch \
+           file://0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch \
           "
 
 SRC_URI[md5sum] = "04622bc4d3941dc7eb571c52b7c02993"
diff --git a/meta/recipes-devtools/perl/perl/0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch b/meta/recipes-devtools/perl/perl/0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch
new file mode 100644 (file)
index 0000000..aad46f3
--- /dev/null
@@ -0,0 +1,34 @@
+From 58c69d65b19b5f9a35e1f5ce08d2ea47884233d3 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Thu, 27 Dec 2018 00:18:51 -0800
+Subject: [PATCH] Makefile.SH: Pod-Simple requires Getopt-Long
+
+Fixed a race issue when parallel build:
+
+Running pm_to_blib for cpan/Pod-Simple directly
+[snip]
+/path/to/cpan/podlators/../../miniperl "-I../../lib" "-I../../lib" -MExtUtils::MY -e 'MY->fixin(shift)' -- blib/script/pod2man
+Can't locate Getopt/Long.pm in @INC [snip]
+
+Upstream-Status: Submitted[https://www.nntp.perl.org/group/perl.perl5.porters/2018/12/msg253236.html]
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ Makefile.SH | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.SH b/Makefile.SH
+index 9848d55..7a164e7 100755
+--- a/Makefile.SH
++++ b/Makefile.SH
+@@ -189,6 +189,7 @@ dynamic_list=' '
+ dynamic_ext_re="lib/auto/re/re.$dlext"
+ extra_dep='
+ ext/Pod-Functions/pm_to_blib: cpan/Pod-Simple/pm_to_blib cpan/Pod-Escapes/pm_to_blib pod/perlfunc.pod
++cpan/Pod-Simple/pm_to_blib: cpan/Getopt-Long/pm_to_blib
+ '
+ for f in $dynamic_ext; do
+     : the dependency named here will never exist
+-- 
+2.10.2
+
index a644970192557df84c6302acb374a6ec43181d32..7b1ae7fec9386fbe52990cab5f53373740d7c897 100644 (file)
@@ -65,6 +65,7 @@ SRC_URI += " \
         file://perl-5.26.1-guard_old_libcrypt_fix.patch \
         file://CVE-2018-12015.patch \
         file://0001-ExtUtils-MM_Unix.pm-fix-race-issues.patch \
+        file://0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch \
 "
 
 # Fix test case issues