]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-smartpm: fix package metadata not being read from rpm-md feeds
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Thu, 29 Nov 2012 15:33:36 +0000 (15:33 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Dec 2012 12:30:32 +0000 (12:30 +0000)
The XML indexes in rpm-md were being parsed incorrectly leading to the
package metadata (e.g. dependencies) not being read.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/python/python-smartpm/smart-rpm-md-parse.patch [new file with mode: 0644]
meta/recipes-devtools/python/python-smartpm_1.4.1.bb

diff --git a/meta/recipes-devtools/python/python-smartpm/smart-rpm-md-parse.patch b/meta/recipes-devtools/python/python-smartpm/smart-rpm-md-parse.patch
new file mode 100644 (file)
index 0000000..97cecc1
--- /dev/null
@@ -0,0 +1,26 @@
+backends/rpm: fix parsing of rpm-md metadata
+
+If assertions are disabled then the queue.pop() wasn't being executed,
+leading to requires, recommends etc. not being read properly.
+
+Upstream-Status: Pending
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/smart/backends/rpm/metadata.py b/smart/backends/rpm/metadata.py
+index 2c54f39..dc9df22 100644
+--- a/smart/backends/rpm/metadata.py
++++ b/smart/backends/rpm/metadata.py
+@@ -188,7 +188,8 @@ class RPMMetaDataLoader(Loader):
+             elif event == "end":
+-                assert queue.pop() is elem
++                popped = queue.pop()
++                assert popped is elem
+                 if skip:
+                     if tag == skip:
+-- 
+1.7.9.5
+
index ff153a77d0177465776e4f749883747db857dca6..2d0f7cd641e1733e02db223c5f8ae9fa53c6855c 100644 (file)
@@ -11,7 +11,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
 
 DEPENDS = "python rpm"
-PR = "r1"
+PR = "r2"
 SRCNAME = "smart"
 
 SRC_URI = "\
@@ -19,6 +19,7 @@ SRC_URI = "\
           file://smartpm-rpm5-nodig.patch \
           file://smart-rpm-root.patch \
           file://smart-recommends.patch \
+          file://smart-rpm-md-parse.patch \
           "
 
 SRC_URI[md5sum] = "573ef32ba177a6b3c4bf7ef04873fcb6"