]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: ensure all of Python is installed in nativesdk
authorRoss Burton <ross.burton@intel.com>
Mon, 1 Dec 2014 16:26:55 +0000 (16:26 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 11 Feb 2015 17:39:52 +0000 (17:39 +0000)
If any part of Python gets installed in a SDK, we need to ensure that all of
Python gets installed to avoid replacing python in the environment with a
minimal package set.

[ YOCTO #6735 ]

(From OE-Core rev: e36ff98a7a4da478bb886f61005cd72a0b5a9c0e)

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/python/python_2.7.3.bb

index 2547ea41c81d838ae145bc285725cccee7d88d3d..bada39bcfed59b6a93c2a83e3e7cf70959e8cd34 100644 (file)
@@ -160,6 +160,7 @@ require python-${PYTHON_MAJMIN}-manifest.inc
 # manual dependency additions
 RPROVIDES_${PN}-core = "${PN}"
 RRECOMMENDS_${PN}-core = "${PN}-readline"
+RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python-modules"
 RRECOMMENDS_${PN}-crypt = "openssl"
 RRECOMMENDS_${PN}-crypt_class-nativesdk = "nativesdk-openssl"