]> code.ossystems Code Review - openembedded-core.git/commitdiff
cracklib: fix for base_libdir == libdir
authorJoshua Lock <joshua.lock@collabora.co.uk>
Tue, 1 Dec 2015 21:41:00 +0000 (21:41 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 8 Dec 2015 10:20:07 +0000 (10:20 +0000)
Don't try and move the python packages from base_libdir to libdir
if they are the same location.

Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/cracklib/cracklib_2.9.5.bb

index c0ffe33160fd09856af1850d48e05883405612ea..23f259c6a6c59d45ddfacd98f89ebd4c8a6c8402 100644 (file)
@@ -28,10 +28,13 @@ do_install_append() {
        src_dir="${D}${base_libdir}/${PYTHON_DIR}/site-packages"
        rm -f $src_dir/*.pyo
        rm -f $src_dir/test_cracklib.py
-       # Move python files from ${base_libdir} to ${libdir} since used --libdir=${base_libdir}
-       install -d -m 0755 ${D}${PYTHON_SITEPACKAGES_DIR}/
-       mv $src_dir/* ${D}${PYTHON_SITEPACKAGES_DIR}
-       rm -fr ${D}${base_libdir}/${PYTHON_DIR}
+
+       if [ "${base_libdir}" != "${libdir}" ] ; then
+          # Move python files from ${base_libdir} to ${libdir} since used --libdir=${base_libdir}
+          install -d -m 0755 ${D}${PYTHON_SITEPACKAGES_DIR}/
+          mv $src_dir/* ${D}${PYTHON_SITEPACKAGES_DIR}
+          rm -fr ${D}${base_libdir}/${PYTHON_DIR}
+       fi
 }
 
 BBCLASSEXTEND = "native nativesdk"