]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox: update 1.7.2 to 1.8.1
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 16 Nov 2007 15:41:54 +0000 (15:41 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 16 Nov 2007 15:41:54 +0000 (15:41 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3186 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/busybox/busybox-1.7.2/run_parts.c [deleted file]
meta/packages/busybox/busybox-1.8.1/busybox-mdev.sh [moved from meta/packages/busybox/busybox-1.7.2/busybox-mdev.sh with 100% similarity]
meta/packages/busybox/busybox-1.8.1/defconfig [moved from meta/packages/busybox/busybox-1.7.2/defconfig with 100% similarity]
meta/packages/busybox/busybox-1.8.1/udhcpscript.patch [moved from meta/packages/busybox/busybox-1.7.2/udhcpscript.patch with 100% similarity]
meta/packages/busybox/busybox_1.8.1.bb [moved from meta/packages/busybox/busybox_1.7.2.bb with 88% similarity]

diff --git a/meta/packages/busybox/busybox-1.7.2/run_parts.c b/meta/packages/busybox/busybox-1.7.2/run_parts.c
deleted file mode 100644 (file)
index 56f70c6..0000000
+++ /dev/null
@@ -1,174 +0,0 @@
-/* vi: set sw=4 ts=4: */
-/*
- * Mini run-parts implementation for busybox
- *
- * Copyright (C) 2007 Bernhard Fischer
- *
- * Based on a older version that was in busybox which was 1k big..
- *   Copyright (C) 2001 by Emanuele Aina <emanuele.aina@tiscali.it>
- *
- * Based on the Debian run-parts program, version 1.15
- *   Copyright (C) 1996 Jeff Noxon <jeff@router.patch.net>,
- *   Copyright (C) 1996-1999 Guy Maor <maor@debian.org>
- *
- *
- * Licensed under GPL v2 or later, see file LICENSE in this tarball for details.
- */
-
-/* This is my first attempt to write a program in C (well, this is my first
- * attempt to write a program! :-) . */
-
-/* This piece of code is heavily based on the original version of run-parts,
- * taken from debian-utils. I've only removed the long options and a the
- * report mode. As the original run-parts support only long options, I've
- * broken compatibility because the BusyBox policy doesn't allow them.
- * The supported options are:
- * -t                  test. Print the name of the files to be executed, without
- *                             execute them.
- * -a ARG              argument. Pass ARG as an argument the program executed. It can
- *                             be repeated to pass multiple arguments.
- * -u MASK             umask. Set the umask of the program executed to MASK.
- */
-
-#include <getopt.h>
-
-#include "libbb.h"
-
-struct globals {
-       char **names;
-       int    cur;
-       char  *cmd[1];
-};
-#define G (*(struct globals*)&bb_common_bufsiz1)
-#define names (G.names)
-#define cur   (G.cur  )
-#define cmd   (G.cmd  )
-
-enum { NUM_CMD = (COMMON_BUFSIZE - sizeof(struct globals)) / sizeof(cmd[0]) };
-
-enum {
-       RUN_PARTS_OPT_a = (1 << 0),
-       RUN_PARTS_OPT_u = (1 << 1),
-       RUN_PARTS_OPT_t = (1 << 2),
-       RUN_PARTS_OPT_l = (1 << 3) * ENABLE_FEATURE_RUN_PARTS_FANCY,
-};
-
-#if ENABLE_FEATURE_RUN_PARTS_FANCY
-#define list_mode (option_mask32 & RUN_PARTS_OPT_l)
-#else
-#define list_mode 0
-#endif
-
-/* Is this a valid filename (upper/lower alpha, digits,
- * underscores, and hyphens only?)
- */
-static bool invalid_name(const char *c)
-{
-       c = bb_basename(c);
-
-       while (*c && (isalnum(*c) || *c == '_' || *c == '-'))
-               c++;
-
-       return *c; /* TRUE (!0) if terminating NUL is not reached */
-}
-
-static int bb_alphasort(const void *p1, const void *p2)
-{
-       return strcmp(*(char **) p1, *(char **) p2);
-}
-
-static int act(const char *file, struct stat *statbuf, void *args, int depth)
-{
-       if (depth == 1)
-               return TRUE;
-
-       if (depth == 2
-        && (  !(statbuf->st_mode & (S_IFREG | S_IFLNK))
-           || invalid_name(file)
-           || (!list_mode && access(file, X_OK) != 0))
-       ) {
-               return SKIP;
-       }
-
-       names = xrealloc(names, (cur + 2) * sizeof(names[0]));
-       names[cur++] = xstrdup(file);
-       names[cur] = NULL;
-
-       return TRUE;
-}
-
-#if ENABLE_FEATURE_RUN_PARTS_LONG_OPTIONS
-static const char runparts_longopts[] ALIGN1 =
-       "arg\0"     Required_argument "a"
-       "umask\0"   Required_argument "u"
-       "test\0"    No_argument       "t"
-#if ENABLE_FEATURE_RUN_PARTS_FANCY
-       "list\0"    No_argument       "l"
-//TODO: "reverse\0" No_argument       "r"
-//TODO: "verbose\0" No_argument       "v"
-#endif
-       ;
-#endif
-
-int run_parts_main(int argc, char **argv);
-int run_parts_main(int argc, char **argv)
-{
-       const char *umask_p = "22";
-       llist_t *arg_list = NULL;
-       unsigned n;
-       int ret;
-
-#if ENABLE_FEATURE_RUN_PARTS_LONG_OPTIONS
-       applet_long_options = runparts_longopts;
-#endif
-       /* We require exactly one argument: the directory name */
-       opt_complementary = "=1:a::";
-       getopt32(argv, "a:u:t"USE_FEATURE_RUN_PARTS_FANCY("l"), &arg_list, &umask_p);
-
-       umask(xstrtou_range(umask_p, 8, 0, 07777));
-
-       n = 1;
-       while (arg_list && n < NUM_CMD) {
-               cmd[n] = arg_list->data;
-               arg_list = arg_list->link;
-               n++;
-       }
-       /* cmd[n] = NULL; - is already zeroed out */
-
-       /* run-parts has to sort executables by name before running them */
-
-       recursive_action(argv[optind],
-                       ACTION_RECURSE|ACTION_FOLLOWLINKS,
-                       act,            /* file action */
-                       act,            /* dir action */
-                       NULL,           /* user data */
-                       1               /* depth */
-               );
-
-       if (!names)
-               return 0;
-
-       qsort(names, cur, sizeof(char *), bb_alphasort);
-
-       n = 0;
-       while (1) {
-               char *name = *names++;
-               if (!name)
-                       break;
-               if (option_mask32 & (RUN_PARTS_OPT_t | RUN_PARTS_OPT_l)) {
-                       puts(name);
-                       continue;
-               }
-               cmd[0] = name;
-               ret = wait4pid(spawn(cmd));
-               if (ret == 0)
-                       continue;
-               n = 1;
-               if (ret < 0)
-                       bb_perror_msg("failed to exec %s", name);
-               else /* ret > 0 */
-                       bb_error_msg("%s exited with return code %d", name, ret);
-       }
-
-       return n;
-}
similarity index 88%
rename from meta/packages/busybox/busybox_1.7.2.bb
rename to meta/packages/busybox/busybox_1.8.1.bb
index e446a19d960c2e5434f87c6f49bec510f3184f6a..0cd757cc9b298e4dc4d73a6780997bcdd2beaba9 100644 (file)
@@ -15,21 +15,11 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
            file://syslog.conf \
            file://udhcpscript.patch;patch=1 \
            file://umount.busybox \
-          file://run_parts.c"
-
-
-SRC_URI += "http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-ash.patch;patch=1 \
-            http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-iptun.patch;patch=1 \
-           http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-logger.patch;patch=1 \
-           http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-tail.patch;patch=1 \
-            file://defconfig"
+           file://defconfig"
 
 EXTRA_OEMAKE_append = " V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
 
 do_configure () {
-       # default run-parts does not sort entries == X11 session broken
-       install -m 0644 ${WORKDIR}/run_parts.c ${S}/debianutils/
-
        install -m 0644 ${WORKDIR}/defconfig ${S}/.config
        cml1_do_configure
 }