]> code.ossystems Code Review - openembedded-core.git/commitdiff
go: Remove -fPIE -pie from SECURITY_PIE_CFLAGS
authorKhem Raj <raj.khem@gmail.com>
Mon, 24 Jul 2017 00:47:48 +0000 (17:47 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 9 Aug 2017 08:24:02 +0000 (09:24 +0100)
External compilers will explicitly pass -fPIE -pie flags
unlike internal toolchain which does not use them, so the build
fails with external toolchains because, its passing these
flags to linker when building with -r option and fails to link

| /mnt/a/oe/build/tmp/work/corei7-64-bec-linux/go/1.8.3-r0/recipe-sysroot-native/usr/bin/x86_64-bec-linux/x86_64-bec-linux-ld: -r and -pie may not be used together

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/go/go_1.8.bb

index 091b1318af6d730f0bbcab166a5fc08ca9e537d3..ef8bc143833afae9c37fb8554f0909944812465b 100644 (file)
@@ -1,3 +1,4 @@
 require go-${PV}.inc
 require go.inc
 TUNE_CCARGS_remove = "-march=mips32r2"
+SECURITY_PIE_CFLAGS_remove = "-fPIE -pie"