]> code.ossystems Code Review - openembedded-core.git/commitdiff
oe-core: take UPSTREAM_CHECK_COMMITS into use where possible
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Tue, 14 Nov 2017 14:57:29 +0000 (16:57 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Nov 2017 23:41:36 +0000 (23:41 +0000)
This greatly reduces the amount of recipes for which upstream
version check fails: from about 30 to about 8.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
22 files changed:
meta/recipes-core/dbus-wait/dbus-wait_git.bb
meta/recipes-core/psplash/psplash_git.bb
meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
meta/recipes-devtools/build-compare/build-compare_git.bb
meta/recipes-devtools/gnu-config/gnu-config_git.bb
meta/recipes-devtools/llvm/llvm_git.bb
meta/recipes-devtools/mmc/mmc-utils_git.bb
meta/recipes-devtools/prelink/prelink_git.bb
meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
meta/recipes-extended/go-examples/go-helloworld_0.1.bb
meta/recipes-graphics/fstests/fstests_git.bb
meta/recipes-graphics/kmscube/kmscube_git.bb
meta/recipes-graphics/piglit/piglit_git.bb
meta/recipes-graphics/vulkan/vulkan-demos_git.bb
meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_git.bb
meta/recipes-graphics/xorg-lib/libxcalibrate_git.bb
meta/recipes-graphics/xorg-proto/calibrateproto_git.bb
meta/recipes-graphics/xvideo-tests/xvideo-tests_git.bb
meta/recipes-kernel/linux-firmware/linux-firmware_git.bb
meta/recipes-multimedia/gstreamer/gst-player_git.bb
meta/recipes-multimedia/x264/x264_git.bb
meta/recipes-sato/puzzles/puzzles_git.bb

index 4afb90c20a5ae8919f26a89c5d0a012e021b125e..c24295b5370b543bba202e308a05c8f1e3a37829 100644 (file)
@@ -11,7 +11,7 @@ PV = "0.1+git${SRCPV}"
 PR = "r2"
 
 SRC_URI = "git://git.yoctoproject.org/${BPN}"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index 3b7f818fc567d6843c8d5703ef8447dbb5dbd53f..aab2c0360deee621c3c12bacb5d0a2e5cccee9f7 100644 (file)
@@ -12,7 +12,7 @@ PR = "r15"
 SRC_URI = "git://git.yoctoproject.org/${BPN} \
            file://psplash-init \
            ${SPLASH_IMAGES}"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 SPLASH_IMAGES = "file://psplash-poky-img.h;outsuffix=default"
 
index 6fc6f6e1abe0597ba4217ca4c3c1890da79ed5fe..76d4312d88129923d38805a962f002f60462ae23 100644 (file)
@@ -16,7 +16,7 @@ SRC_URI = "git://github.com/philb/update-rc.d.git \
            file://check-if-symlinks-are-valid.patch \
            file://fix-to-handle-priority-numbers-correctly.patch \
           "
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index 84d04cfa0d33c6e7e685c9ba9d3d253a3a6f864b..efcf6b6dd3c0d2f76ca76661e4d99d5130879e51 100644 (file)
@@ -22,7 +22,7 @@ SRC_URI = "git://github.com/openSUSE/build-compare.git \
 SRCREV = "c5352c054c6ef15735da31b76d6d88620f4aff0a"
 PE = "1"
 PV = "2015.02.10+git${SRCPV}"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index 4fded60f19751f25c10c136e02be4e7863a8dc34..8de8138127678ca752de4fe16a684ff967812d93 100644 (file)
@@ -14,7 +14,7 @@ PV = "20150728+git${SRCPV}"
 SRC_URI = "git://git.savannah.gnu.org/config.git \
            file://gnu-configize.in"
 S = "${WORKDIR}/git"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 CLEANBROKEN = "1"
 
index b3069ec1fbbabe24f2ad502b25078a1075b08b3a..de06e12ae460ff4568241f5ae6b6d13acac841af 100644 (file)
@@ -26,7 +26,7 @@ SRC_URI = "git://github.com/llvm-mirror/llvm.git;branch=release_50;protocol=http
            file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \
            file://0002-llvm-allow-env-override-of-exe-path.patch \
           "
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 S = "${WORKDIR}/git"
 
 LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
index 50acdb1cc2ac35b40b30b0604d76bc373f81c69f..efaabc114821c1a0fc20e35dfc82dd819de39d2b 100644 (file)
@@ -9,7 +9,7 @@ SRCREV = "37c86e60c0442fef570b75cd81aeb1db4d0cbafd"
 PV = "0.1"
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${SRCBRANCH}"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index 570ef36a3cce5307e56d06a3b77b97c17a22cad0..cc93bcc384f8501ffafd72568455d1c09e1e98e0 100644 (file)
@@ -32,8 +32,7 @@ SRC_URI = "git://git.yoctoproject.org/prelink-cross.git;branch=cross_prelink \
            file://prelink.cron.daily \
            file://prelink.default \
           file://macros.prelink"
-UPSTREAM_CHECK_GITTAGREGEX = "upstream has no usable tags"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 TARGET_OS_ORIG := "${TARGET_OS}"
 OVERRIDES_append = ":${TARGET_OS_ORIG}"
index 0f991706c1e944e5d50e6300bd460c29aa3df66d..a8baca51e3fc3176a0ef676003682d378596654f 100644 (file)
@@ -16,7 +16,7 @@ SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \
            file://squashfs-tools-4.3-sysmacros.patch;striplevel=2 \
            file://fix-compat.patch \
 "
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
 SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
 
index 6d6789ae852b2d5f635d652259ffc81a8452432c..ab70ea98a32643af80269109cec9201bd7f394cc 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
 
 SRC_URI = "git://${GO_IMPORT}"
 SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 GO_IMPORT = "github.com/golang/example"
 GO_INSTALL = "${GO_IMPORT}/hello"
index 9e09cd2685b8641561dc1c4b16ecaebf18545d32..69f217830af54e985750e305e058f594f713f278 100644 (file)
@@ -8,7 +8,7 @@ SRCREV = "e5939ff608b95cdd4d0ab0e1935781ab9a276ac0"
 PV = "0.1+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/${BPN}"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 LIC_FILES_CHKSUM = "file://test-pango-gdk.c;endline=24;md5=1ee74ec851ecda57eb7ac6cc180f7655"
 
index cab68fffb4354548f607947668750317cbae120b..4265f8a8dc175fcf273a69169a8b260a8bbacccc 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://kmscube.c;beginline=1;endline=23;md5=8b309d4ee67b7315
 
 SRCREV = "0d8de4ce3a03f36af1817f9b0586d132ad2c5d2e"
 SRC_URI = "git://anongit.freedesktop.org/mesa/kmscube;branch=master;protocol=git"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index d274a8fbd56e2210ddf9ea430dbed3922f94d772..bbe9a88969ed5d0da1cc581b6cbaf24377a5432b 100644 (file)
@@ -6,7 +6,7 @@ SRC_URI = "git://anongit.freedesktop.org/piglit \
            file://0001-cmake-install-bash-completions-in-the-right-place.patch \
            file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
            "
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 # From 2017-07-03
 SRCREV = "c8f4fd9eeb298a2ef0855927f22634f794ef3eff"
index 0b8943508b8ea367651b36c0367e93af44ecfea9..5fc9c2dba75139cc9bab6ce2a6a6595b681c67f7 100644 (file)
@@ -10,7 +10,7 @@ SRC_URI = "git://github.com/SaschaWillems/Vulkan.git \
            file://0001-Don-t-build-demos-with-questionably-licensed-data.patch \
            file://0001-Fix-build-on-x86.patch \
 "
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 SRCREV = "18df00c7b4677b0889486e16977857aa987947e2"
 UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
 S = "${WORKDIR}/git"
index 733ebce7450f3a7f1c596818d701b2968b403423..a4ab7f6eb81e8b01c794a0032ce85d11ed099f44 100644 (file)
@@ -11,7 +11,7 @@ SRCREV = "23c8af5ba4a1b7efbaf0bbca59a65ff7e10a1a06"
 PV = "0.1.1+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index 7c7fa3ddb3cea5b3efcef09556b9a333b32e6fd6..0fe65318bea7ba0d738296b0d6c212f8760d483f 100644 (file)
@@ -16,7 +16,7 @@ PV = "0.0+git${SRCPV}"
 
 SRC_URI = "git://anongit.freedesktop.org/git/xorg/lib/libXCalibrate \
            file://fix-xcb.patch"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index 3a989262c1d707657eaae83acca5994b4d0be235..eb4b4224cae3576eb21e501e93f38dcf837a7a24 100644 (file)
@@ -17,5 +17,5 @@ PR = "r2"
 SRC_URI = "git://anongit.freedesktop.org/git/xorg/proto/calibrateproto \
            file://fix.patch;apply=yes"
 S = "${WORKDIR}/git"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
index 2667dd899d9b1b6c5621bdda5b811c003329d20b..1d275a0042ce3c9829fe3e47c46441e8b9c2fef7 100644 (file)
@@ -8,7 +8,7 @@ SRCREV = "7d38b881e99eb74169d292b40f7164e461a65092"
 PV = "0.1+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/test-xvideo"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index 9054b33cc0f93d2c19b0f628b128d19f112000b3..8433308a864d97333f8b7f8809573657dd67106a 100644 (file)
@@ -184,7 +184,7 @@ PV = "0.0+git${SRCPV}"
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git"
 
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index 4fe8fdef4a207b037a7ab37de37799211624270a..ee11e2ba10d23c87f1136d8d02a84049d169efee 100644 (file)
@@ -9,7 +9,7 @@ SRC_URI = "git://github.com/sdroege/gst-player.git \
 
 SRCREV = "ee3c226c82767a089743e4e06058743e67f73cdb"
 PV = "0.0.1+git${SRCPV}"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 S = "${WORKDIR}/git"
 
index c5476c7a9b3149b745ccc0e792bf5f3c1159678b..bc9775ab2a16cc3b27da1cf9c8c007c76462bbc4 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/mirror/x264;branch=stable \
            file://don-t-default-to-cortex-a9-with-neon.patch \
            file://Fix-X32-build-by-disabling-asm.patch \
            "
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 
 SRCREV = "2b741f81e51f92d053d87a49f59ff1026553a0f6"
 
index decd2a8b30008babce45eb926260f752217f7f0f..6148e40adaa8c4bc77d21d4107b764d3d5842f3d 100644 (file)
@@ -16,7 +16,7 @@ SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
            file://0001-Clarify-conditions-to-avoid-compiler-errors.patch \
            file://0001-Use-Wno-error-format-overflow-if-the-compiler-suppor.patch \
            "
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_COMMITS = "1"
 SRCREV = "8dfe5cec31e784e4ece2955ecc8cc35ee7e8fbb3"
 PE = "1"
 PV = "0.0+git${SRCPV}"