]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox: upgrade to version 1.18.4
authorQing He <qing.he@intel.com>
Mon, 25 Apr 2011 06:06:48 +0000 (14:06 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 May 2011 23:50:55 +0000 (00:50 +0100)
from version 1.17.3
 - remove make-382-fix since it's upstreamed

Signed-off-by: Qing He <qing.he@intel.com>
meta/recipes-core/busybox/busybox-1.17.3/make-382-fix.patch [deleted file]
meta/recipes-core/busybox/busybox-1.18.4/B921600.patch [moved from meta/recipes-core/busybox/busybox-1.17.3/B921600.patch with 100% similarity]
meta/recipes-core/busybox/busybox-1.18.4/busybox-appletlib-dependency.patch [moved from meta/recipes-core/busybox/busybox-1.17.3/busybox-appletlib-dependency.patch with 100% similarity]
meta/recipes-core/busybox/busybox-1.18.4/busybox-udhcpc-no_deconfig.patch [moved from meta/recipes-core/busybox/busybox-1.17.3/busybox-udhcpc-no_deconfig.patch with 90% similarity]
meta/recipes-core/busybox/busybox-1.18.4/defconfig [moved from meta/recipes-core/busybox/busybox-1.17.3/defconfig with 100% similarity]
meta/recipes-core/busybox/busybox-1.18.4/get_header_tar.patch [moved from meta/recipes-core/busybox/busybox-1.17.3/get_header_tar.patch with 76% similarity]
meta/recipes-core/busybox/busybox-1.18.4/run-parts.in.usr-bin.patch [moved from meta/recipes-core/busybox/busybox-1.17.3/run-parts.in.usr-bin.patch with 100% similarity]
meta/recipes-core/busybox/busybox-1.18.4/udhcpc-fix-nfsroot.patch [moved from meta/recipes-core/busybox/busybox-1.17.3/udhcpc-fix-nfsroot.patch with 100% similarity]
meta/recipes-core/busybox/busybox-1.18.4/udhcpscript.patch [moved from meta/recipes-core/busybox/busybox-1.17.3/udhcpscript.patch with 100% similarity]
meta/recipes-core/busybox/busybox_1.18.4.bb [moved from meta/recipes-core/busybox/busybox_1.17.3.bb with 81% similarity]

diff --git a/meta/recipes-core/busybox/busybox-1.17.3/make-382-fix.patch b/meta/recipes-core/busybox/busybox-1.17.3/make-382-fix.patch
deleted file mode 100644 (file)
index 4ef125d..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-From ef6c6d8cfef071435ccf275ad404a501626b706c Mon Sep 17 00:00:00 2001
-From: Thomas Chou <thomas@wytron.com.tw>
-Date: Tue, 19 Oct 2010 07:17:12 +0000
-Subject: mkmakefile: make 3.82 fix
-
-Signed-off-by: Thomas Chou <thomas@wytron.com.tw>
-Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
----
-diff --git a/scripts/mkmakefile b/scripts/mkmakefile
-index 7f9d544..9fc51a7 100755
---- a/scripts/mkmakefile
-+++ b/scripts/mkmakefile
-@@ -31,6 +31,9 @@ all:
- Makefile:;
--\$(filter-out all Makefile,\$(MAKECMDGOALS)) %/:
-+\$(filter-out all Makefile,\$(MAKECMDGOALS)):
-+      \$(MAKE) -C \$(KERNELSRC) O=\$(KERNELOUTPUT) \$@
-+
-+%/:
-       \$(MAKE) -C \$(KERNELSRC) O=\$(KERNELOUTPUT) \$@
- EOF
---
-cgit v0.8.2.1
similarity index 90%
rename from meta/recipes-core/busybox/busybox-1.17.3/busybox-udhcpc-no_deconfig.patch
rename to meta/recipes-core/busybox/busybox-1.18.4/busybox-udhcpc-no_deconfig.patch
index cdf56b826ca97abc01bbec0a70be108380085387..405d4823af36594b0484666b1aeb90f3c643cae8 100644 (file)
@@ -1,3 +1,5 @@
+Upstream-Status: Pending
+
 Add a new option -D to the udhcpc client that allows for
 dhcp renewal to occur without having to down the interface
 in the process.
@@ -8,6 +10,11 @@ Updated to latest Busybox 1.17.3
 
 Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
 
+Updated to Busybox 1.18.4
+option spec is changed
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
 diff -ur busybox-1.17.3.orig/networking/udhcp/dhcpc.c busybox-1.17.3/networking/udhcp/dhcpc.c
 --- busybox-1.17.3.orig/networking/udhcp/dhcpc.c
 +++ busybox-1.17.3/networking/udhcp/dhcpc.c
@@ -42,10 +49,10 @@ diff -ur busybox-1.17.3.orig/networking/udhcp/dhcpc.c busybox-1.17.3/networking/
        bb_info_msg("Entering released state");
  
 @@ -836,6 +841,7 @@
-               OPT_o = 1 << 18,
-               OPT_x = 1 << 19,
-               OPT_f = 1 << 20,
-+              OPT_D = 1 << 21,
+               OPT_o = 1 << 17,
+               OPT_x = 1 << 18,
+               OPT_f = 1 << 19,
++              OPT_D = 1 << 20,
  /* The rest has variable bit positions, need to be clever */
                OPTBIT_f = 20,
                USE_FOR_MMU(             OPTBIT_b,)
@@ -53,8 +60,8 @@ diff -ur busybox-1.17.3.orig/networking/udhcp/dhcpc.c busybox-1.17.3/networking/
  #endif
                ;
        IF_LONG_OPTS(applet_long_options = udhcpc_longopts;)
--      opt = getopt32(argv, "c:CV:H:h:F:i:np:qRr:s:T:t:SA:O:ox:f"
-+      opt = getopt32(argv, "c:CV:H:h:F:i:np:qRr:s:T:t:SA:O:ox:fD"
+-      opt = getopt32(argv, "CV:H:h:F:i:np:qRr:s:T:t:SA:O:ox:f"
++      opt = getopt32(argv, "CV:H:h:F:i:np:qRr:s:T:t:SA:O:ox:fD"
                USE_FOR_MMU("b")
                IF_FEATURE_UDHCPC_ARPING("a")
                IF_FEATURE_UDHCP_PORT("P:")
similarity index 76%
rename from meta/recipes-core/busybox/busybox-1.17.3/get_header_tar.patch
rename to meta/recipes-core/busybox/busybox-1.18.4/get_header_tar.patch
index bc9b427ea9b0b74b3d44a0cc087b4ce13937fed2..c1f881fbd792751c7062a098820741a6525c0523 100644 (file)
@@ -7,8 +7,8 @@
 #
 # above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
 
---- busybox-1.13.2/archival/libunarchive/get_header_tar.c.orig 2008-11-09 18:28:02.000000000 +0100
-+++ busybox-1.13.2/archival/libunarchive/get_header_tar.c      2009-02-11 22:34:52.000000000 +0100
+--- busybox-1.13.2/archival/libarchive/get_header_tar.c.orig   2008-11-09 18:28:02.000000000 +0100
++++ busybox-1.13.2/archival/libarchive/get_header_tar.c        2009-02-11 22:34:52.000000000 +0100
 @@ -252,6 +252,8 @@
                        file_header->name = concat_path_file(tar.prefix, tar.name);
                } else
similarity index 81%
rename from meta/recipes-core/busybox/busybox_1.17.3.bb
rename to meta/recipes-core/busybox/busybox_1.18.4.bb
index 28342feaf0362306bb60f2f72919548ada0e5250..696a4db09bf2c5a8886761f69c00d7a983c42801 100644 (file)
@@ -1,5 +1,5 @@
 require busybox.inc
-PR = "r2"
+PR = "r0"
 
 SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
            file://udhcpscript.patch \
@@ -8,7 +8,6 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
            file://get_header_tar.patch \
            file://busybox-appletlib-dependency.patch \
            file://run-parts.in.usr-bin.patch \
-           file://make-382-fix.patch \
            file://busybox-udhcpc-no_deconfig.patch \
            file://find-touchscreen.sh \
            file://busybox-cron \
@@ -24,7 +23,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
            file://umount.busybox \
            file://defconfig"
 
-SRC_URI[tarball.md5sum] = "a2ce1a951571da8c6e0eaf75b1acef60"
-SRC_URI[tarball.sha256sum] = "de2f0274f61a068d75ad33861e0982e99c6b625681460ce420222371c3511ff2"
+SRC_URI[tarball.md5sum] = "b03c5b46ced732679e525a920a1a62f5"
+SRC_URI[tarball.sha256sum] = "4d24d37bd6f1bd153e8cf9a984ec2f32f18464f73ca535e2cc2e8be9694097fa"
 
 EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"